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Corrección de problemas de autenticación en aplicaciones de Microsoft 365 al intentar conectarse a un servicio de Microsoft 365

Síntomas

Se produce un error de autenticación automáticamente en algunas aplicaciones de Microsoft 365 y Outlook puede entrar en el estado "Necesitar contraseña" sin ninguna interacción. Además, al realizar una llamada API de Administrador de cuentas web a FindAllAccountsAsync, es posible que vea el código de error "-2147024809" en los registros de Microsoft Entra o en los registros de cliente de Microsoft 365.

Importante

Este problema solo se produce en equipos que ejecutan Windows 10, versión 1703 o posterior, y Microsoft 365 versión 1807 o posterior.

Causa

El problema de autenticación se produce debido a la falta de información del paquete sobre la biblioteca de autenticación de Active Directory (ADAL) o Live ID.

Resolución

Sugerencia

Para diagnosticar y corregir automáticamente varios problemas comunes de inicio de sesión de Microsoft 365, ejecute el solucionador de problemas de inicio de sesión de Microsoft 365.

Para corregir este problema, use PowerShell para volver a instalar los paquetes para el complemento WAM de Microsoft Entra (para cuentas organizativas o profesionales) y Live ID (para cuentas personales como @outlook.com, @hotmail.com, etc.). Para ello, siga estos pasos:

  1. Haga clic con el botón derecho en el icono de Windows en la barra de tareas y, a continuación, seleccione Windows PowerShell (administrador).

  2. Si se le pide una ventana de Control de cuentas de usuario (UAC), seleccione para iniciar PowerShell.

  3. Si el problema se trata de una cuenta profesional, debe corregir el paquete del complemento Microsoft Entra WAM. Ejecute el siguiente comando en la consola de comandos:

    if (-not (Get-AppxPackage Microsoft.AAD.BrokerPlugin)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.AAD.BrokerPlugin
    
  4. Si el problema se trata de una cuenta personal, debe corregir el paquete de Live ID. Ejecute el siguiente comando en la consola de comandos:

    if (-not (Get-AppxPackage Microsoft.Windows.CloudExperienceHost)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.Windows.CloudExperienceHost
    

Después de ejecutar los comandos y, si se completaron sin errores, es posible que vea un indicador de progreso rápido o un resultado de estado que contenga información sobre la instalación del paquete.