Error "No se puede enviar correo electrónico como usuario seleccionado" al enviar un correo electrónico como otro usuario
En este artículo se presentan posibles causas y una resolución para el error "No se puede enviar correo electrónico como usuario seleccionado" que se produce cuando se envía un correo electrónico en nombre de otro usuario en Microsoft Dynamics 365.
Se aplica a: Microsoft Dynamics 365
Número de KB original: 3184980
Síntomas
Al intentar enviar un correo electrónico estableciendo el campo From (Desde ) en otro usuario de Dynamics 365, recibirá el siguiente mensaje de error:
No puede enviar correo electrónico como usuario seleccionado. El usuario seleccionado no ha permitido esto o no tiene suficientes privilegios para hacerlo. Póngase en contacto con el administrador del sistema para obtener ayuda.
Al seleccionar el botón Descargar registro , la sección Mensaje muestra la siguiente información:
<Message>User no tiene privilegios de envío.</Mensaje>
Causa
Este problema se produce si existe una de las siguientes condiciones:
El rol de seguridad de Dynamics 365 no tiene el privilegio Enviar correo electrónico como otro usuario .
Nota:
Si usa una regla de flujo de trabajo para enviar el correo electrónico, el propietario de la regla de flujo de trabajo necesita este privilegio.
El usuario que intenta enviar como no ha habilitado la opción que permite a otros usuarios enviar un correo electrónico en su nombre.
Solución
Para resolver este problema:
Un administrador debe comprobar que el usuario tiene un rol en Dynamics 365 que incluye el privilegio Enviar correo electrónico como otro usuario .
Inicie sesión en Microsoft Dynamics 365.
Seleccione Configuración Opciones avanzadas>Configuración>>Roles de seguridad de>seguridad.
Abra el rol de seguridad asignado al usuario que recibe el mensaje de error.
Seleccione Privilegios varios de administración empresarial>.
Compruebe que el usuario tiene el privilegio Enviar correo electrónico como otro usuario . Si el usuario no tiene el privilegio, asígnelo y, a continuación, seleccione Guardar.
Nota:
El privilegio Enviar correo electrónico como otro usuario tiene distintos niveles de profundidad. Un usuario necesita una profundidad suficiente en este privilegio para que coincida con el usuario que intenta enviar como. Por ejemplo, si intenta enviar como usuario que se encuentra en una unidad de negocio diferente dentro de Dynamics 365, tener acceso de nivel de unidad de negocio para este privilegio no sería suficiente, ya que solo le permitiría enviar como otros usuarios en la misma unidad de negocio.
El otro usuario que se establece como remitente en el correo electrónico debe seleccionar la casilla Permitir que otros usuarios de Microsoft Dynamics 365 envíen correo electrónico en su nombre en sus opciones personales.
- Inicie sesión en Dynamics 365 como el usuario que intenta enviar un correo electrónico como.
- Seleccione el icono de engranaje en la esquina superior derecha y, a continuación, seleccione Opciones>Configuración de configuración>Correo electrónico de configuración>de personalización.
- Compruebe que está seleccionada la opción Permitir que otros usuarios de Microsoft Dynamics 365 envíen correo electrónico en su nombre . Si no es así, seleccione la opción y, a continuación, seleccione Aceptar.