Leer en inglés

Compartir a través de


Es posible que el servicio SQL Server no se inicie después de instalar la revisión

Este artículo le ayuda a resolver el problema que se produce después de que el instalador de revisiones instale una revisión e intente reiniciar el sistema.

Versión del producto original: SQL Server
Número de KB original: 961301

Síntoma

Es posible que reciba un mensaje que indica que no se pudo iniciar un servicio de SQL Server. SQL Server no se puede reiniciar después de que el instalador de revisiones instale una revisión e intente reiniciar el sistema. El mensaje de error se mostrará en la pantalla o aparecerá en el registro de summary.txt .

Causa

Esto puede deberse a que un servicio SQL se está ejecutando, pero la contraseña ha expirado. Cuando el instalador de revisiones intente reiniciar el servicio SQL, se producirá un error al reiniciarse.

Solución

Si recibe un mensaje que indica que no se pudo iniciar un servicio de SQL Server, para solucionar el problema, compruebe lo siguiente:

  • Determine el error. Se mostrará un mensaje en la interfaz de usuario o en el registro de summary.txt ubicado en %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log.

  • Compruebe si el tipo de servicio de inicio es automático o manual.

  • Compruebe que la cuenta y la contraseña son válidas y no han expirado. Un servicio podría haberse ejecutado anteriormente con una cuenta o contraseña no válidas.

  • Si el servicio motor de base de datos no se iniciará, después de comprobar las credenciales del servicio y el inicio, compruebe el ERRORLOG. ErrorLOG se puede encontrar en C:\Archivos de programa\Microsoft SQL Server\<Id.> de instancia\MSSQL\LOG.