Error AADSTS50011 al consultar el almacenamiento de datos de Intune

Este artículo le ayuda a corregir un problema en el que recibe el error "La dirección URL de respuesta especificada en la solicitud no coincide con las direcciones URL de respuesta configuradas para la aplicación" al consultar el almacenamiento de datos de Intune.

Síntoma

Al consultar El almacenamiento de datos de Intune mediante PowerShell o una aplicación personalizada, recibirá un mensaje de error que contiene lo siguiente:

AADSTS50011: la dirección URL de respuesta especificada en la solicitud no coincide con las direcciones URL de respuesta configuradas para la aplicación: "<id. de aplicación asignado por Azure AD>".

Causa

Este problema se produce si se quita el URI de redirección predeterminado para el registro de la aplicación o PowerShell.

Solución

Para solucionar este problema, haga lo siguiente:

  • Si usa PowerShell, asegúrese de que el URI de redirección predeterminado está establecido.

    Este es un ejemplo:

    PowerShell
    $redirectUri = "urn:ietf:wg:oauth:2.0:oob"
    
  • Si usa una aplicación personalizada, siga estos pasos:

    1. Inicie sesión en el portal de Azure.

    2. Seleccione Microsoft Entra ID> Registros de aplicaciones.

    3. En el cuadro de búsqueda, escriba el identificador de aplicación en el mensaje de error para buscar la aplicación.

    4. Seleccione la aplicación y, a continuación, seleccione Autenticación en Administrar.

    5. En URI de redirección, agregue el siguiente URI:

      Tipo: Cliente público (móvil y escritorio)
      URI de redirección: urn:ietf:wg:oauth:2.0:oob

      Captura de pantalla del tipo y el valor del URI de redirección.

Más información

Para obtener más información sobre los URI de redirección y el registro de aplicaciones, consulte Incorporación de URI de redirección a la aplicación.