Una cita se cancela o elimina inesperadamente durante la sincronización del lado servidor

En este artículo se proporciona una solución a un problema por el que una cita se cancela o elimina inesperadamente cuando se usa la sincronización del lado servidor en Microsoft Dynamics 365.

Se aplica a: Microsoft Dynamics 365
Número de KB original: 4345686

Síntomas

Cuando se usa la sincronización del lado servidor para sincronizar citas entre Microsoft Dynamics 365 y Exchange, una cita se cancela o elimina inesperadamente.

Causa

Este problema puede producirse si la cita ya no cumple las condiciones de los filtros de sincronización del usuario. Como se explica en Omitir elementos eliminados lógicamente durante la sincronización, hay varias razones por las que una cita ya no coincide con los filtros de sincronización. Estos motivos incluyen cambios en el organizador de citas, los filtros de sincronización y los roles de seguridad o la configuración de uso compartido, lo que hace que el usuario pierda el acceso al registro. De forma predeterminada, la sincronización del lado servidor envía una operación de eliminación a Exchange en este escenario, lo que conduce a la cancelación de la cita.

Solución

Como administrador, puede modificar este comportamiento cambiando la DistinctPhysicalAndLogicalDeletesForExchangeSync configuración a True mediante una de las siguientes herramientas:

  1. Editor de configuración de la organización. Para obtener más información sobre cómo usar la herramienta para editar la configuración, consulte Configuración de base de datos de entorno.
  2. Herramienta OrgDBOrgSettings para Microsoft Dynamics 365

Al actualizar esta configuración, puede administrar cómo se controlan las eliminaciones durante la sincronización y evitar cancelaciones inesperadas de citas.