Error "El usuario del buzón no tiene permisos suficientes" al probar y habilitar un buzón

En este artículo se proporciona una solución a un error de permisos que se produce al intentar probar y habilitar un buzón en Microsoft Dynamics 365.

Se aplica a: Microsoft Dynamics 365
Número de KB original: 4052824

Síntomas

Al intentar probar y habilitar un buzón en Dynamics 365, se registra la siguiente alerta:

Las citas, los contactos y las tareas no se pueden sincronizar para el nombre> del buzón de correo porque el usuario del buzón <de correo no tiene permisos suficientes en este buzón.

Código de error del servidor de correo electrónico: Crm.80048306.No es suficiente privilegio para acceder al objeto Microsoft Dynamics 365 o realizar la operación solicitada.

Si selecciona ver los detalles, se muestran los siguientes detalles adicionales:

T:195
ActivityId: <GUID>
>Excepción: Excepción no controlada: Microsoft.Crm.CrmSecurityException: Se produjo un error en SecLib::AccessCheckEx. Se devuelve hr = -2147187962, ObjectID: <GUID>, OwnerId: <GUID>, OwnerIdType: 8 y CallingUser: <GUID>. ObjectTypeCode: 4120, objectBusinessUnitId: <GUID>, AccessRights: WriteAccess at Microsoft.Crm.BusinessEntities.SecurityLibrary.AccessCheckEx2(ExecutionContext context, SecurityPrincipal principal, SecurityPrincipal ownerPrincipal, Guid objectId, Int32 objectTypeCode, Guid objectBusinessUnitId, AccessRights rights) at Microsoft.Crm.Sync.EmailConnector.ExchangeSyncUtility.HasExchangeSyncIdMappingAccess(Guid userId, Int32 userIdTypeCode, IACTProviderContext orgContext) en Microsoft.Crm.Asincrónico.EmailConnector.ExchangeSyncWorker.PerformPreMailboxSyncChecks() en Microsoft.Crm.Asincrónico.EmailConnector.ExchangeS...

Causa

El usuario de Dynamics 365 asociado al buzón no tiene privilegios suficientes. Este problema suele producirse porque el usuario no tiene asignado un rol de seguridad o su rol de seguridad carece de acceso de lectura o escritura de nivel de usuario a la Mailbox entidad.

Garrantzitsua

Compruebe que el propietario del registro de buzón coincide con el usuario. Por ejemplo, si el buzón pertenece a Paul Cannon, asegúrese de que el valor propietario del registro también sea Paul Cannon. Si muestra un usuario diferente, es posible que ese usuario no tenga acceso al buzón de Paul Cannon.

Solución

Siga estos pasos para solucionar este problema:

  1. Abra el registro de buzón como usuario con el rol "Administrador del sistema" en Dynamics 365.

    Argibidea

    La alerta incluye un vínculo al registro del buzón.

  2. Compruebe que el campo Propietario del formulario de buzón tenga el nombre del usuario. Si aparece otro nombre, cámbielo al nombre del usuario.

  3. Seleccione el vínculo en el campo Propietario para abrir el registro de usuario para el usuario propietario.

  4. Seleccione Administrar roles para ver qué roles de seguridad se asignan al usuario.

  5. Vaya a Configuración, seleccione Seguridad y, a continuación, seleccione Roles de seguridad.

  6. Abra los roles que se encuentran en el paso 4. Consulte El error PrivilegeDenied se produce al usar la sincronización del lado servidor para obtener una lista de privilegios necesarios y, a continuación, compruebe que el rol de seguridad del usuario contiene estos privilegios.

  7. Después de comprobar que el usuario es el propietario del registro del buzón y que su rol de seguridad contiene los privilegios necesarios, seleccione el botón Probar y habilitar buzón de nuevo en el registro de buzón. Si la prueba no da como resultado Correcto, revise el mensaje que se muestra en la sección Alertas .