Error "Excepción prohibida del servidor HTTP devuelto" al probar un buzón de Dynamics 365

En este artículo se proporciona una solución a un error que se produce al seleccionar el botón Probar y habilitar buzón en un registro de buzón en Microsoft Dynamics 365.

Se aplica a: Microsoft Dynamics 365
Número de KB original: 4483440

Síntomas

Al seleccionar el botón Probar y habilitar buzón en un registro de buzón en Dynamics 365, la sección de resultados de la prueba muestra Error y se registra la siguiente alerta:

No se puede enviar el mensaje de correo electrónico "El buzón ahora está conectado a Dynamics 365" porque se produjo un error al establecer una conexión segura con el servidor de correo electrónico. Buzón [Nombre del buzón] no se sincronice. Se ha notificado al propietario del perfil de servidor de correo electrónico Microsoft Exchange Online.
Código de error del servidor de correo electrónico: el servidor HTTP devolvió la excepción Prohibido.

Si selecciona Detalles, se muestran los detalles siguientes:

Error: System.Net.WebException: Error en la solicitud con el estado HTTP 403: Prohibido.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
en Microsoft.Crm.Sync.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

Causa

Dynamics 365 se comunica con Microsoft Exchange mediante solicitudes de Servicios web de Exchange (EWS). Si EWS está deshabilitado, se produce este error. Estas son algunas formas posibles de deshabilitar o restringir EWS en Exchange:

  1. EWS está deshabilitado para el buzón.
  2. EWS está deshabilitado para toda la organización.
  3. EwsApplicationAccessPolicy se establece en EnforceAllowList y EwsAllowList no permite el acceso desde Dynamics 365.
  4. EwsApplicationAccessPolicy se establece en EnforceBlockList y EwsBlockList incluye Dynamics 365.

Solución

Compruebe si EWS está deshabilitado para el buzón si el problema solo se produce para algunos buzones

  1. En primer lugar, compruebe si EWS está deshabilitado para un buzón específico mediante este comando de PowerShell:

    PowerShell
    Get-CASMailbox <mailbox-alias> | ft EwsEnabled
    
  2. Si EwsEnabled está establecido en False, habilite mediante este comando:

    PowerShell
    Set-CASMailbox <mailbox-alias> -EwsEnabled $True
    

    Garrantzitsua

    Después de ejecutar este comando, puede tardar hasta 120 minutos antes de que el cambio de configuración surta efecto.

Compruebe si EWS está deshabilitado en el nivel de organización o si EwsAllowList limita el tráfico de EWS.

  1. Use este comando de PowerShell para comprobar la configuración de nivel de organización:

    PowerShell
    Get-OrganizationConfig |ft Name, EwsEnabled,EwsApplicationAccessPolicy,EwsBlockList,EwsAllowList
    
  2. Asegúrese de que EwsEnabled no está establecido en False. Si es así, habilite mediante:

    PowerShell
    Set-OrganizationConfig -EwsEnabled $True
    

    Garrantzitsua

    Después de ejecutar este comando, puede tardar hasta 120 minutos antes de que el cambio de configuración surta efecto.

  3. Si EwsApplicationAccessPolicy se establece en EnforceAllowList, compruebe si EwsAllowList contiene un valor para CRM (por ejemplo, CRM/*) para permitir que Dynamics 365 (CRM) se comunique con Exchange. Si no es así, use el siguiente comando para actualizar la lista para incluir CRM/* y cualquier otra aplicación que quiera permitir. En este ejemplo <PreviousAllowedList> es la lista de aplicaciones que estaban anteriormente en la lista de permitidos:

    PowerShell
    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceAllowList -EwsAllowList:CRM/*,<PreviousAllowedList>
    

    Garrantzitsua

    Después de ejecutar este comando, puede tardar hasta 120 minutos antes de que el cambio de configuración surta efecto.

  4. Si EwsApplicationAccessPolicy se establece en EnforceBlockList, compruebe si EwsBlockList contiene un valor para CRM (por ejemplo, CRM/*), lo que impide que Dynamics 365 (CRM) se comunique con Exchange. Si lo hace, use el siguiente comando para actualizar la lista para que ya no incluya CRM. En este ejemplo <PreviousBlockList WITH CRM REMOVED> es la lista de aplicaciones que se encontraban anteriormente en la lista de bloqueos excepto para CRM:

    PowerShell
    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceBlockList -EwsBlockList:<PreviousBlockList WITH CRM REMOVED>
    

    Garrantzitsua

    Después de ejecutar este comando, puede tardar hasta 120 minutos antes de que el cambio de configuración surta efecto.

Más información

Para obtener más información sobre cómo cambiar la configuración de Exchange mediante PowerShell y controlar el acceso a EWS, consulte los siguientes artículos: