The SMTP address has no mailbox associated with it.
Cause
This error can occur if the User Name field in the email server profile record is populated using the domain\username format instead of the UPN format (for example, contoso\user).
Resolution
Use the UPN format (for example, user@contoso.com) for the User Name field instead of the domain\username format in the Credentials section of the email server profile record.
If the user name is in the UPN format and you still receive this error, verify that the user has a mailbox and that the UPN value in the User Name field matches the email address for the user's mailbox in Exchange.
More information
The following is an example of the error message and additional information about the failure shown in the Failure Details section:
XML
Request to Exchange::
\<TraceTag="EwsRequestHttpHeaders"Tid="534"Time="\<Date>">
POST /EWS/Exchange.asmx HTTP/1.1
Content-Type: text/xml; charset=utf-8
Accept: text/xml
User-Agent: ExchangeServicesClient/15.00.1076.004
Accept-Encoding: gzip,deflate
</Trace><TraceTag="EwsRequest"Tid="534"Time="\<Date>"Version="15.00.1076.004"><?xml version="1.0" encoding="utf-8"?><soap:Envelopexmlns:xsi="https://www.w3.org/2001/XMLSchema-instance"xmlns:m="https://schemas.microsoft.com/exchange/services/2006/messages"xmlns:t="https://schemas.microsoft.com/exchange/services/2006/types"xmlns:soap="https://schemas.xmlsoap.org/soap/envelope/"><soap:Header><t:RequestServerVersionVersion="Exchange2010" /><t:ExchangeImpersonation><t:ConnectingSID><t:SmtpAddress>domain\username</t:SmtpAddress></t:ConnectingSID></t:ExchangeImpersonation></soap:Header><soap:Body><m:FindFolderTraversal="Shallow"><m:FolderShape><t:BaseShape>AllProperties</t:BaseShape></m:FolderShape><m:IndexedPageFolderViewMaxEntriesReturned="1"Offset="0"BasePoint="Beginning" /><m:ParentFolderIds><t:DistinguishedFolderIdId="inbox" /></m:ParentFolderIds></m:FindFolder></soap:Body></soap:Envelope></Trace>
Response from Exchange:
\<TraceTag="EwsResponseHttpHeaders"Tid="534"Time="2016-12-19 19:00:22Z">
HTTP/1.1 500 Internal Server Error
...
</Trace><TraceTag="EwsResponse"Tid="534"Time="2016-12-19 19:00:22Z"Version="15.00.1076.004"><?xml version="1.0" encoding="utf-8"?><s:Envelopexmlns:s="https://schemas.xmlsoap.org/soap/envelope/"><s:Body><s:Fault><faultcodexmlns:a="https://schemas.microsoft.com/exchange/services/2006/types">a:ErrorNonExistentMailbox>
<faultstringxml:lang="en-US">The SMTP address has no mailbox associated with it.</faultstring><detail><e:ResponseCodexmlns:e="https://schemas.microsoft.com/exchange/services/2006/errors">ErrorNonExistentMailbox>
<e:Messagexmlns:e="https://schemas.microsoft.com/exchange/services/2006/errors">The SMTP address has no mailbox associated with it.</e:Message><t:MessageXmlxmlns:t="https://schemas.microsoft.com/exchange/services/2006/types"><t:ValueName="SmtpAddress">domain\username</t:Value></t:MessageXml></detail></s:Fault></s:Body></s:Envelope></Trace>
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