Une erreur de Dynamics 365 Microsoft interne s’est produite lors de la synchronisation des rendez-vous, des contacts et des tâches

Cet article fournit une solution à une erreur qui se produit après la sélection de Test & Activer la boîte aux lettres sur un enregistrement de boîte aux lettres dans Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de la base de connaissances d’origine : 4346733

Symptômes

Après avoir sélectionné Test & Activer la boîte aux lettres sur un enregistrement de boîte aux lettres dans Dynamics 365, le résultat du test Rendez-vous, Contacts et Tâches s’affiche comme Échec et le message suivant s’affiche dans la section Alertes :

« Une erreur de Dynamics 365 Microsoft interne s’est produite lors de la synchronisation des rendez-vous, des contacts et des tâches pour la boîte aux lettres [Nom de la boîte aux lettres]. La boîte aux lettres n’a pas été synchronisée. Le propriétaire du profil de serveur de messagerie associé [Email Nom du profil de serveur] a été averti.
code d’erreur du serveur Email : UserPrivilegeError »

Cause

Si vous voyez ce message d’erreur et que le code d’erreur du serveur Email s’affiche sous la forme UserPrivilegeError, ce qui indique que l’utilisateur propriétaire de cette boîte aux lettres ne dispose pas des privilèges suffisants. Consultez L’erreur PrivilegeDenied se produit lors de l’utilisation de la synchronisation Server-Side pour obtenir la liste des privilèges requis.

Importante

Vérifiez que le propriétaire de l’enregistrement de boîte aux lettres est identique à l’utilisateur. Exemple : si la boîte aux lettres est une boîte aux lettres utilisateur pour Paul Cannon, vérifiez que la valeur Propriétaire dans l’enregistrement de boîte aux lettres de Paul Cannon s’affiche sous la forme Paul Cannon. S’il s’agit d’un autre utilisateur, il se peut que cet utilisateur n’ait pas accès à la boîte aux lettres de cet utilisateur.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. En tant qu’utilisateur disposant du rôle Administrateur système, ouvrez l’enregistrement de boîte aux lettres dans Dynamics 365.

    Remarque

    L’alerte inclut un lien vers l’enregistrement de boîte aux lettres.

  2. Vérifiez que le champ Propriétaire du formulaire de boîte aux lettres est rempli avec le nom de l’utilisateur. Si un autre utilisateur est répertorié, modifiez-le pour qu’il soit identique à cet utilisateur.
  3. Sélectionnez le lien dans le champ Propriétaire pour ouvrir l’enregistrement Utilisateur de l’utilisateur propriétaire.
  4. Sélectionnez Gérer les rôles pour voir quel(s) rôle(s) de sécurité est attribué à cet utilisateur.
  5. Accédez à Paramètres, sélectionnez Sécurité, puis rôles de sécurité.
  6. Ouvrez les rôles trouvés à l’étape 4. Consultez L’erreur PrivilegeDenied se produit lors de l’utilisation de la synchronisation Server-Side pour obtenir la liste des privilèges requis et vérifier que le rôle de sécurité de l’utilisateur contient ces privilèges.
  7. Après avoir vérifié que l’utilisateur est le propriétaire de son enregistrement de boîte aux lettres et que son rôle de sécurité contient les privilèges requis, sélectionnez à nouveau le bouton Tester & Activer la boîte aux lettres dans son enregistrement de boîte aux lettres. Si le test n’aboutit pas à la réussite, passez en revue le message qui s’affiche dans la section Alertes.