Code d’erreur 80040203 erreur (argument non valide) se produit lorsque vous essayez d’importer une solution dans Microsoft Dynamics 365

Cet article fournit une solution à une erreur qui se produit lorsque vous essayez d’importer une solution dans Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics 365 Customer Engagement Online
Numéro de la base de connaissances d’origine : 4514229

Symptômes

Lorsque vous essayez d’importer une solution dans Dynamics 365, le message d’erreur suivant s’affiche :

« L’importation de la solution : <Le nom> de la solution a échoué.
Code d’erreur 80040203. »

Remarque

Ce code d’erreur est documenté dans les codes d’erreur du service Web avec les informations suivantes :

Nom : InvalidArgument
Hexadécimal : 80040203
Numéro : -2147220989
Argument non valide.

Cause

Cette erreur peut être due à plusieurs raisons. Si votre boîte de dialogue d’erreur fait référence au type d’objet suivant, consultez le reste de cet article pour trouver une solution potentielle :

Type : Relation
Nom : bpf_<entity>_<publisher>_<BPF Name>

Téléchargez le fichier journal qui, lorsqu’il est ouvert sur la page Composants, affiche :

ItemType : relation d’entité
Nom : bpf_<entity>_<publisher>_<BPF Name>
ErrorCode : 0x80040203
ErrorText : Attribute Display Name for id : <GUID>, objectcolumn : DisplayName et labelTypeCode : Attribute not specified

Le nom de la relation d’entité est la concaténation d’une entité et d’un flux de processus métier (BPF). L’entité a été précédemment supprimée d’une phase BPF et remplacée par une autre entité, puis le BPF a été mis à jour tout en étant toujours activé. L’entité a été supprimée du BPF, mais la relation existe toujours dans le schéma. Il est donc exporté avec la solution à partir de la source. Cette relation provoque l’affichage de l’erreur.

Résolution

Microsoft est conscient de ce problème et travaille sur une modification pour supprimer cette relation après une suppression, puis une mise à jour.

Il y a deux solutions de contournement dans ce cas :

Option 1 : Mettre à jour le fichier solution

Si vous avez besoin d’importer la solution et que vous ne pouvez pas recréer le package de solution, supprimez la relation de la solution.

  1. Décompressez la solution.

  2. Modifiez le customization.xml.

  3. Recherchez la relation mentionnée dans l’erreur : bpf_<entity>_<publisher>_<BPF Name>

  4. Supprimez tout le code XML pour EntityRelationship :

    <EntityRelationship Name="bpf_<entity>_<publisher>_<BPF Name>">
    ...
    </EntityRelationship>
    
  5. Enregistrez le fichier.

  6. Compressez l’intégralité du répertoire.

  7. Réimportez la solution.

Option 2 - Supprimer la relation de la source et recréer votre solution

Il s’agit d’une résolution à long terme qui résout le problème pour l’exportation suivante de la solution.

  1. Ouvrez le organization source.

  2. Sélectionnez Paramètres / Personnalisations / Personnaliser le système

  3. Sélectionnez l’entité dans la relation :

    bpf_<entity>_<publisher>_<BPF Name>
    
  4. Développez relations 1 :N.

  5. Recherchez la relation :

    bpf_<entity>_<publisher>_<BPF Name>
    
  6. Sélectionnez et supprimez la relation.

  7. Publier toutes les personnalisations.

  8. Exportez la solution et importez-la dans la cible.