Le nombre actuel de KMS n’augmente pas lorsque vous ajoutez de nouveaux ordinateurs clients Windows Vista ou Windows 7 au réseau
Cet article fournit de l’aide pour résoudre un problème où le nombre de clients sur un ordinateur KMS (Key Management Server) n’augmente pas lorsque vous ajoutez de nouveaux ordinateurs clients Windows Vista au réseau.
S’applique à :Windows 7 Service Pack 1
Numéro de base de connaissances d’origine : 929829
Symptômes
Lorsque vous exécutez le script Slmgr.vbs sur un ordinateur KMS (Key Management Server), vous vérifiez que le nombre d’ordinateurs clients n’augmente pas lorsque vous ajoutez de nouveaux ordinateurs clients Windows au réseau. En outre, vous pouvez voir l’événement suivant dans le journal des événements du service de gestion des clés pour chaque nouvel ordinateur client Windows que vous ajoutez au réseau.
Lorsque vous exécutez le script Slmgr.vbs avec l’argument -dli
, les informations de nombre d’ordinateurs clients n’augmentent pas comme prévu. Dans l’événement suivant journalisé dans le journal des événements du service de gestion des clés, le nombre actuel reste le même.
Cause
Ce problème peut se produire lorsque les ordinateurs clients Windows que vous ajoutez au réseau ont des ID de machine client KMS identiques (CMID). Le nombre actuel augmente sur un ordinateur KMS lorsque les ordinateurs clients ont des CMID différents. Deux ordinateurs ou plus peuvent avoir les mêmes CMID dans l’un des scénarios suivants :
- L’image Windows personnalisée que vous utilisez pour installer l’ordinateur client est générée même si vous n’exécutez pas l’outil de préparation du système (Sysprep.exe) avec l’option /generalize.
- L’image Windows personnalisée est générée avec l’option /generalize. Toutefois, vous spécifiez le <paramètre SkipRearm> dans le fichier Unattended.xml.
Pour vérifier que les ordinateurs clients ont des CMID identiques, procédez comme suit :
Sur l’un des ordinateurs clients Windows, cliquez sur Démarrer, pointez sur Programmes, pointez sur Accessoires, cliquez avec le bouton droit sur Invite de commandes , puis cliquez sur Exécuter en tant qu’administrateur. Si vous êtes invité à entrer un mot de passe administrateur ou une confirmation, tapez le mot de passe ou cliquez sur Autoriser.
À l’invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :
cscript c:\windows\system32\slmgr.vbs -dli
Examinez les résultats suivants et notez l’ID CMID.
Répétez les étapes 1 à 4 sur un deuxième ordinateur client Windows. Vérifiez que le CMID du deuxième ordinateur client est identique à l’ID CMID du premier ordinateur.
Résolution
Nous vous recommandons de régénérer l’image de base utilisée pour déployer les ordinateurs affectés dès que vous déterminez s’ils ont des CMID identiques.
Solution de contournement
La solution de contournement est valide uniquement si l’option /generalize a été utilisée dans l’image utilisée pour installer des clients Windows. Cette option est requise lorsque vous déployez plusieurs images. Pour déterminer si l’option /generalize a été utilisée dans l’image, procédez comme suit :
Sur l’un des ordinateurs affectés, cliquez sur Démarrer, puis tapez C:\Windows\System32\sysprep\Panther\setupact.log.
Examinez les lignes « SYSPRP ParseCommands: Found », comme indiqué dans l’exemple de fichier journal suivant :
Info [0x0f004e] Journal SysPrep initialisé SYSPRP sur C:\Windows\System32\sysprep\Panther
Info [0x0f0054] SYSPRP ValidateUser:User dispose des privilèges requis pour sysprep machine
Info [0x0f0056] La version de SYSPRP ValidateVersion:OS est correcte
Info [0x0f005c] SYSPRP ScreenSaver:Successfully disabled screen saver for sysprep
Info [0x0f007e] SYSPRP FCreateTagFile:Tag file C:\Windows\System32\sysprep\Sysprep_succeeded.tag n’existe pas déjà, il n’est pas nécessaire de supprimer quoi que ce soit
Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'UNATTEND'
Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'OOBE'
Info [0x0f005f] Option de ligne de commande prise en charge par SYSPRP ParseCommands :Found supported command line option 'SHUTDOWN'
Info [0x0f005f] Option de ligne de commande prise en charge par SYSPRP ParseCommands :Found supported command line option 'GENERALIZE'Si l’option /generalize est présente, vérifiez que cette option a été utilisée sur l’ordinateur qui a créé l’image de base.
Si l’option /generalize a été utilisée et que vous avez des ordinateurs qui ont des CMID identiques, suivez ces étapes pour réarmer les ordinateurs affectés et reconstruire l’image de base. Assurez-vous que vous n’utilisez pas le <paramètre SkipRearm> :
Sur l’un des ordinateurs clients de base Windows, cliquez sur Démarrer, pointez sur Programmes, pointez sur Accessoires, cliquez avec le bouton droit sur Invite de commandes, puis cliquez sur Exécuter en tant qu’administrateur.
Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer, tapez le mot de passe ou cliquez sur Autoriser.
À l’invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :
cscript c:\windows\system32\slmgr.vbs -rearm
Redémarrez l'ordinateur.
Si l’image de base n’a pas été générée à l’aide de Sysprep avec l’option /generalize, vous devez reconstruire l’image de base, puis réinstaller Windows sur les clients. Si vous utilisez un fichier Unattended.xml lorsque vous régénérez l’image de base, assurez-vous que le <paramètre SkipRearm> n’est pas utilisé. Pour plus d’informations sur le <paramètre SkipRearm>, consultez la documentation Kit d'installation automatisée (Windows AIK) (Windows AIK).
Plus d’informations
Pour réinitialiser le minuteur d’activation et définir un CMID unique, le processus de réarmement doit s’exécuter sur l’ordinateur de destination. Ce processus est utilisé pour réinitialiser l’état d’activation. Dans Windows, le processus de réarmement peut être exécuté à l’aide de l’une des deux méthodes suivantes :
- Exécutez Sysprep avec l’option /generalize sur l’ordinateur utilisé pour générer l’image Windows personnalisée.
- Forcez le processus de réarmement en exécutant le script Slmgr.vbs dans une fenêtre d’invite de commandes avec élévation de privilèges. Par exemple, tapez :
cscript c:\windows\system32\slmgr.vbs -rearm
Si le processus réarmer ne s’est pas exécuté parce que Sysprep a été exécuté avec l’option /generalize ou parce que vous avez utilisé le <paramètre SkipRearm>1</SkipRearm> dans le fichier Unattended.xml, les ordinateurs clients peuvent avoir des CMID identiques. Par conséquent, les informations de nombre d’ordinateurs n’augmentent pas comme prévu. L’option /generalize est requise lorsque vous déployez plusieurs images. Le <paramètre SkipRearm> ne doit pas être utilisé dans un fichier sans assistance lorsque vous déployez des ordinateurs dans un environnement de production. Par conséquent, dans les deux cas, nous vous recommandons de régénérer l’image de base.