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Type de données incorrect pour l’erreur « SCRIPT_CMD_COLUMNOFTABLE » lors de la création d’un fichier EFT dans Microsoft Dynamics GP

Cet article fournit des options pour résoudre l’erreur SCRIPT_CMD_COLUMNOFTABLE qui se produit lors de la création d’un fichier EFT dans Microsoft Dynamics GP.

S’applique à : Microsoft Dynamics GP
Numéro de base de connaissances d’origine : 4043888

Symptômes

Lors de la génération d’un fichier EFT, ce message d’erreur est reçu :

Exception de script non gérée :
Type de données incorrect détecté pour l’opération EXCEPTION_CLASS_SCRIPT_BAD_TYPE
SCRIPT_CMD_COLUMNOFTABLE

Cause

COLUMNOFTABLE signifie qu’il existe une colonne mappée dans le configurateur qui n’existe pas dans la table correspondante sélectionnée pour ce champ. Malheureusement, il n’existe pas de moyen simple d’identifier la ligne/le champ dans le fichier configurator dans lequel se trouve la table/champ incompatible.

Résolution

Pour résoudre ce problème, consultez les options ci-dessous :

Option 1 : la meilleure façon consiste à ouvrir le format de fichier EFT et à parcourir chaque champ de type de données où un nom de table et un nom de champ sont mappés. Réélectionnez simplement le nom du champ à l’aide du bouton Rechercher pour chaque champ. Vous allez exécuter un champ à un moment donné qui n’est pas dans le bouton de recherche, car il n’est pas dans la table répertoriée.

  1. Ouvrez le fichier de configuration EFT (Cards>Financial>EFT File Format) et sélectionnez l’ID de format EFT utilisé.
  2. Sélectionnez le premier type de ligne d’en-tête de fichier, puis développez les mappages de lignes détaillés ci-dessous.
  3. Pour chaque type de ligne de champ de données, le nom de la table et le nom de champ sont répertoriés. Sélectionnez simplement le bouton Rechercher pour le nom du champ, puis réélectionnez le nom du champ dans la liste de sélection. Effectuez cette opération pour toutes les lignes de champ de données.
  4. Répétez le type de ligne suivant (en-tête batch, détail, et ainsi de suite) et réélectionnez le nom du champ pour toutes les lignes de type de données. Vous en trouverez finalement un dans le fichier où le champ n’est pas dans la liste de sélections, et c’est la cause. Sélectionnez la table/le champ approprié, puis vous pouvez enregistrer vos modifications et tester à nouveau. (En règle générale, les utilisateurs n’en ont qu’un, donc testez à ce stade avant de vérifier le reste des lignes dans le fichier.)

L’option 2 - Toutes les tables du bouton de recherche concernent le module incorrect.

Si vous êtes dans un format de fichier EFT Payables et que vous voyez uniquement les tables Clients dans la liste de sélections de table, ou si vous êtes dans un format de fichier Clients et que seules les tables Payables répertoriées dans le configurator, il y a eu un problème quand le fichier a été importé, et la valeur SERIES incorrecte est stockée sur le format de fichier.

Remarque

Ce n’est généralement pas le problème de l’utilisateur. Il s’agit généralement uniquement d’un problème pour l’utilisateur qui a importé le fichier. Par conséquent, si vous rencontrez ce problème, car vous avez importé le fichier, utilisez les étapes ci-dessous pour le corriger, puis avez probablement besoin d’effectuer l’option 1 ci-dessus.

  1. Exécutez ce script dans SQL Server Management Studio sur la base de données d’entreprise pour afficher l’ID de format de fichier EFT :

    SQL
    select SERIES, * from CM00103
    
  2. Passez en revue la valeur SERIES de votre ID de format de fichier EFT.

    • 3 - Créances
    • 4 - Payables
  3. Si la série incorrecte est référencée, vous pouvez simplement mettre à jour la série, de sorte que vous voyez la table correcte dans le serveur frontal.

    SQL
    select update CM00103 set SERIES = 4 where EFTFORMATID = 'xxx'
    

    mettez à jour l’EFTFormatID avec le nom de votre fichier configurator pour le xxx. Modifiez la valeur de série sur 3 ou 4 en fonction des besoins.