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Erreur « Ce numéro de document existe déjà » lors de la sélection d’une facture dans la fenêtre Entrée de transaction commerciale

Cet article fournit une résolution du problème que vous ne pouvez pas sélectionner une facture dans la fenêtre Entrée de transaction commerciale dans le traitement des commandes commerciales dans Microsoft Dynamics GP ou dans Microsoft Business Solutions - Great Plains.

S’applique à : Microsoft Dynamics GP
Numéro de base de connaissances d’origine : 865449

Symptômes

Lorsque vous essayez de sélectionner une facture dans la fenêtre Entrée de transaction commerciale dans le traitement des commandes commerciales dans Microsoft Dynamics GP ou dans Microsoft Business Solutions - Great Plains, vous recevez le message d’erreur suivant :

Ce numéro de document existe déjà.

Cause

Ce problème peut se produire si la connexion réseau est fermée lorsque vous publiez une facture de vente.

Résolution

Pour résoudre ce problème, effectuez les opérations suivantes :

  1. Dans le menu Enquête , pointez sur Ventes, puis sélectionnez Documents commerciaux.

  2. Pour déterminer si le même document apparaît également dans l’historique, sélectionnez Unposted, sélectionnez le document que vous avez entré, puis sélectionnez Historique.

  3. Si la transaction apparaît dans un état non publié et dans l’historique, assurez-vous que la transaction est publiée dans le registre général. Si la transaction a été publiée correctement dans le registre général, passez à l’étape 4. Si la transaction n’a pas été publiée correctement dans le registre général, passez à l’étape 7.

  4. Dans le menu Transactions , pointez sur Ventes, puis sélectionnez Lots de ventes.

  5. Sélectionnez le bouton de recherche en regard du champ ID batch, puis double-cliquez sur le lot dans lequel se trouve le document.

  6. Sélectionnez Supprimer, puis sélectionnez Oui lorsque vous êtes invité à supprimer le lot.

  7. Effectuez une sauvegarde complète de la base de données que vous pouvez restaurer si un problème se produit.

  8. Assurez-vous que tous les utilisateurs se déconnectent de Microsoft Dynamics GP.

  9. Utilisez l’étape appropriée :

    • Dans Microsoft Dynamics GP 10.0 ou Microsoft Dynamics GP 2010, pointez sur Outils dans le menu Microsoft Dynamics GP, pointez sur Utilitaires, pointez sur Ventes, puis sélectionnez Supprimer l’historique des ventes.
    • Dans Microsoft Dynamics GP 9.0 et dans Microsoft Business Solutions - Great Plains 8.0, pointez sur Utilitaires dans le menu Outils , pointez sur Ventes, puis sélectionnez Supprimer l’historique des ventes.
  10. Dans la zone Plages , tapez le numéro de document dans le champ De et dans le champ À .

  11. Sélectionnez Insérer pour insérer la restriction, puis sélectionnez Processus. Cochez la case Écran pour imprimer le rapport à l’écran, puis sélectionnez OK.