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« L’index 0 du tableau « VerifyBatchTotals » est hors limites dans le script » Messages d’erreur lors de la recherche d’un lot d’achat dans La gestion des fournisseurs à l’aide de Microsoft Dynamics GP

Cet article fournit une solution aux erreurs qui se produisent lors de la recherche d’un lot d’achat dans La gestion des fournisseurs à l’aide de Microsoft Dynamics GP.

S’applique à : Microsoft Dynamics GP
Numéro de base de connaissances d’origine : 2316165

Symptômes

Lorsque vous accédez à la fenêtre Entrée par lot Payables et essayez de rechercher un lot, vous recevez le message d’erreur suivant :

Exception de script non gérée :
L’index 0 du tableau « VerifyBatchTotals » est hors limites dans le script.
'Batch_Lookup_Scrolling_Window SCROLL_FILL', le script s’est terminé.

Faites ensuite défiler vers le bas dans la fenêtre pour afficher le reste du message :

EXCEPTION_CLASS_SCRIPT_OUT_OF_RANGE
SCRIPT_CMD_INDEX

Lorsque vous sélectionnez OK, vous recevez le message suivant :

L’enregistrement sélectionné a été supprimé.

Cause

Ce message peut être dû à un enregistrement endommagé pour un lot de vérification dans la table maître des définitions de publication SY00500. Ce tableau contient les informations sur les lots du système.

Résolution

Pour résoudre ce problème, recréez la table maître SY00500 Définitions de publication à l’aide de l’une des deux options répertoriées ci-dessous. Vous pouvez recréer cette table à l’aide de la maintenance SQL dans Microsoft Dynamics GP ou à l’aide du kit de ressources gratuit dans la bibliothèque d’outils Professional Services. Les deux options sont répertoriées ci-dessous :

Remarque

Avant de continuer, vérifiez que vous disposez d’une sauvegarde restaurable actuelle ou testez ces étapes dans un environnement de test avant d’appliquer les étapes à votre base de données de production. Restaurez immédiatement votre sauvegarde si vous obtenez des résultats inattendus.

OPTION 1 - UTILISATION DE LA MAINTENANCE SQL

  1. Effectuez une sauvegarde complète de Microsoft Dynamics GP.
  2. Sélectionnez Microsoft Dynamics GP, pointez sur Maintenance, puis sélectionnez SQL.
  3. Sélectionnez la base de données d’entreprise qui reçoit l’erreur.
  4. Dans la liste de tables, sélectionnez Maître des définitions de publication.
  5. Sur le côté droit de la fenêtre, activez chaque case à cocher, puis sélectionnez Traiter.
  6. Sélectionnez Oui dans le message suivant :

    « Vous avez choisi de supprimer des tables ; cela supprime toutes les données qu’ils contiennent. Êtes-vous sûr de vouloir continuer ?

Remarque

Cette procédure recrée la table maître SY00500 - Publication des définitions. Toutefois, vous perdrez temporairement tous les lots non postés. Pour récupérer ces lots non postés, exécutez le programme Check Links sur les sous-modules. Ensuite, rapprochez les lots de Microsoft Great Plains General Ledger. Toutefois, il définit tous les lots définis sur Périodique à usage unique. Vous devez revenir à ces lots périodiques si nécessaire.

Pour récupérer les lots, procédez comme suit.

  1. Si vous utilisez l’option Multi-devise dans Microsoft Dynamics GP Payables Management, exécutez le programme Check Links sur les fichiers logiques historiques payables avant d’exécuter le programme Check Links sur le fichier logique de transaction payables. Si vous utilisez plusieurs devises, vous pouvez ignorer cette étape et passer à l’étape 2.

  2. Pour exécuter le programme Vérifier les liens sur les fichiers suivants, sélectionnez Microsoft Dynamics GP, pointez sur Maintenance, sélectionnez Vérifier les liens, sélectionnez l’un des noms de séries suivants, puis tapez le nom de la table logique correspondante. Suivez cette étape pour les fichiers suivants :

    • Module : Gestion des comptes à payer
      Table de séries/logiques : Série d’achat - Transaction logique à payer

    • Module : Traitement des bons de commande
      Table de séries/logiques : série d’achat - Transaction logique d’achat

    • Module : Gestion des comptes clients
      Table de séries/logiques : Série de ventes - Opérations ouvertes des clients

    • Module : Facturation
      Table série/logique : Série de ventes - Fichier de travail de facture

    • Module : Traitement des commandes commerciales
      Table série/logique : Ventes - Fichier de travail sales

    • Module : Inventaire
      Série/Table logique : Inventaire - Fichier de travail de transaction d’inventaire

    • Module : Facture de matériaux
      Table série/logique : Inventaire - Inventaire - Fichier transactions de facture de matériaux

  3. Si vous utilisez Microsoft Dynamics GP Project Series (PS) Time &Expense, vous devez également exécuter Check Links sur les fichiers suivants. Pour exécuter Check Links sur les fichiers suivants, sélectionnez Fichier, Sélectionnez Maintenance, ps Check links, puis sélectionnez l’un des noms de fichiers suivants. Suivez cette étape pour les fichiers suivants :

    • Lots de feuilles de temps - Transactions de feuille de temps PS
    • Lots de journaux d’actifs - Transactions du journal des ressources PS
    • Lots de journaux de dépenses - Transactions du journal des dépenses PS
    • Lots de transfert d’inventaire - Transactions de transfert d’inventaire PS
    • Lots de bon de commande - Transactions de bon de commande PS
    • Nom de la série : Lots de factures du fournisseur - Transactions de facture fournisseur PS
    • Lots de dépenses des employés - Transactions sur les dépenses des employés ps
    • Lots de facturation - Temps de facturation PS & Transactions de matériaux
  4. Si des lots existent dans le registre général microsoft Dynamics GP, sélectionnez Outils dans le menu Microsoft Dynamics GP, pointez sur Utilitaires, pointez sur Finances, puis sélectionnez Rapprochement. Sélectionnez Lots, puis Rapprochement pour rapprocher vos lots.

  5. Retestez pour vérifier si le message d’erreur a été résolu.

OPTION #2 - Utilisation de la bibliothèque d’outils Professional Services (PSTL)

  1. Effectuez une sauvegarde complète de Microsoft Dynamics GP.

  2. Faites en sorte que tous les utilisateurs se déconnectent de Microsoft Dynamics GP.

  3. Utilisez les étapes ci-dessous pour installer la bibliothèque d’outils de services professionnels (PSTL) et l’ajouter en tant que raccourci dans Microsoft Dynamics GP. Si vous l’avez déjà fait, vous pouvez ignorer cette étape.

    Étapes d’installation de la bibliothèque de services d’outils professionnels (PSTL) :

    1. Visitez ce site CustomerSource pour télécharger PSTL : (Les instructions d’installation sont incluses dans le téléchargement.)

    2. Après avoir installé PSTL, connectez-vous à Microsoft Dynamics GP en tant qu’administrateur système (utilisateur « sa »).

    3. Sélectionnez Oui quand vous êtes invité à inclure un nouveau code.

    4. Pour ajouter PSTL à votre barre de raccourcis, sélectionnez Ajouter, sélectionnez Autre fenêtre, développez Outils de service technique, développez Project, sélectionnez Bibliothèque d’outils professionnels, sélectionnez Ajouter, puis Terminé.

  4. Dans la barre de raccourcis, sélectionnez Outils de service professionnel. Attendez la génération des objets SQL. Lorsque vous êtes invité à entrer des clés d’inscription, sélectionnez Annuler. Vous n’avez pas besoin d’utiliser des clés d’inscription pour utiliser le kit de ressources gratuit.

  5. Sélectionnez Toolkit. Cliquez sur Suivant.

  6. Sous Options du kit de ressources, sélectionnez Recréer des objets SQL, puis sélectionnez Suivant.

  7. En regard de La série, sélectionnez Société.

  8. En regard de Table, sélectionnez SY00500.

  9. Sous Options de maintenance, sélectionnez à la fois la table sélectionnée et recréer les données des tables sélectionnées.

    Important

    Vous devez activer la case à cocher Recréer des données pour les tables sélectionnées afin que les données actuelles de la table soient conservées. Si vous oubliez de le marquer, vous perdrez toutes vos données actuelles et devrez restaurer immédiatement votre sauvegarde.

  10. Sélectionnez Effectuer la maintenance sélectionnée.

  11. Lorsque vous recevez les messages suivants, sélectionnez OK :

    La table sera recréée avec des données

    SY00500 table sera recréée avec des données. Vérifiez qu’une sauvegarde a été effectuée avant de poursuivre SY00500 a été recréée

  12. Retestez pour voir si le message d’erreur a été résolu.

  13. Si vous continuez à recevoir le message d’erreur, nous devons recréer les index de l’SY00800 (activité par lots). Pour ce faire, suivez les étapes ci-dessous pour résoudre le problème : (*Assurez-vous que vous disposez d’une sauvegarde restaurable de votre base de données d’entreprise en cas de perte de données indésirable.)

    1. Sélectionnez le lien Bibliothèque d’outils Professional Services sous l’onglet Raccourcis, puis choisissez d’activer toolkit. La fenêtre Kit de ressources s’affiche.

    2. Sélectionnez Recréer des objets SQL dans la fenêtre Kit de ressources, puis sélectionnez Suivant.

    3. Sélectionnez System pour la série et SY00800 pour la table.

    4. Sous les options de maintenance, sélectionnez Reconstruire les index pour la table sélectionnée.

      Remarque

      Vérifiez qu’aucun utilisateur ne publie ou modifie un lot lorsque les index sont recréés pour cette table. La table SY00800 contient un enregistrement à tout moment où un utilisateur modifie ou publie un lot dans n’importe quel module.

    5. Sélectionnez Effectuer la maintenance sélectionnée pour recréer les index.

Plus d’informations

Si vous avez des lots qui accèdent à la récupération par lots, consultez la base de connaissances : un lot est conservé dans l’état Publication, Réception, Occupé, Marqué, Verrouillé ou Modifié dans Microsoft Dynamics GP pour obtenir des instructions sur la façon de rétablir l’état Disponible du lot.