Support étendu de Databricks Runtime 6.4 (sans support)

Databricks a publié cette image en mars 2021. Elle est prise en charge jusqu’en juin 2022.

Le support étendu de Databricks Runtime 6.4 est destiné aux clients qui utilisent une version Databricks Runtime 6.x non prise en charge ou dont la fin de prise en charge est proche, mais qui ne peuvent pas migrer vers Databricks Runtime 7.x ou 8.x avant la fin de la prise en charge de la version Databricks Runtime 6.4 d’origine le 1er avril 2021. Le support étendu de Databricks Runtime 6.4 utilise Ubuntu 18.04.5 LTS au lieu de la distribution Ubuntu 16.04.6 LTS dépréciée utilisée dans la version Databricks Runtime 6.4 d’origine. La prise en charge d’Ubuntu 16.04.6 LTS a cessé le 1er avril 2021.

Databricks continue de vous recommander de migrer vos charges de travail vers Databricks Runtime 7.x ou 8.x dès que possible pour bénéficier des avantages d’Apache Spark 3.x et des nombreuses nouvelles fonctionnalités et améliorations intégrées à ces nouveaux runtimes. Pour plus d’informations sur la migration, consultez le guide de migration de Databricks Runtime 7.x.

Ces notes de publication répertorient les différences entre le support étendu de Databricks Runtime 6.4 et la version Databricks Runtime 6.4 d’origine. Pour tous les autres détails concernant cette version, consultez les notes de publication de la version Databricks Runtime 6.4 (non pris en charge) d’origine.

Différences entre le support étendu de Databricks Runtime 6.4 et Databricks Runtime 6.4

Les informations d’environnement et les bibliothèques suivantes sont différentes de celles de Databricks Runtime 6.4.

Environnement du système

  • Système d’exploitation : Ubuntu 18.04.5 LTS
  • Java : Zulu 8.52.0.23-CA-linux64 (build 1.8.0_282-b08)

Bibliothèques Python

  • jmespath mise à niveau de 0.9.4 vers 0.10.0
  • kiwisolver mise à niveau de 1.1.0 vers kiwisolver 1.3.1
  • pycurl 7.43.0 supprimée
  • PyGObject mise à niveau de 3.20.0 vers 3.26.1
  • pyparsing mise à niveau de 2.4.6 vers 2.4.7
  • python-apt mise à niveau de 1.1.0.b1+ubuntu0.16.04.11 vers 1.6.5+ubuntu0.5
  • ssh-import-id mise à niveau de 5.5 vers 5.7

Bibliothèques R

  • Rserve mise à niveau de 1.8-6 vers 1.8-7