OWA ou ECP cesse de fonctionner après l’installation d’une mise à jour de sécurité

Symptômes

Après l’installation d’une mise à jour de sécurité sur un serveur Microsoft Exchange Server, les applications Outlook sur le web (OWA) et/ou Panneau de configuration Exchange (ECP) cessent de fonctionner sur le serveur.

OWA affiche le message d’erreur suivant :

Un problème est survenu
Votre recherche n’a pas pu aboutir. Code d’état HTTP : 500

Capture d’écran du message d’erreur OWA.

ECP affiche le message d’erreur suivant :

Erreur du serveur dans l’application « /ecp ».               
Impossible de charger le fichier ou l’assembly « Microsoft.Exchange.Common, Version=15.0.0.0 …Culture=neutral, PublicKeyToken=31bf3856ad364e54 » ou une de ses dépendances. Le fichier spécifié est introuvable.

Capture d’écran du message d’erreur ECP.

Cause

Ces erreurs se produisent si la mise à jour de sécurité a été installée manuellement sur un serveur sur lequel le contrôle de compte d’utilisateur (UAC) est activé, mais sans utiliser d’autorisations élevées.

Résolution

Utilisez des autorisations élevées pour réinstaller la mise à jour de sécurité sur le serveur.

  1. Sélectionnez Démarrer, puis tapez cmd.
  2. Cliquez avec le bouton droit sur Invite de commandes dans les résultats de la recherche, puis sélectionnez Exécuter en tant quʼadministrateur.
  3. Si la fenêtre Contrôle de compte dʼutilisateur sʼaffiche, sélectionnez lʼoption pour ouvrir une fenêtre dʼinvite de commandes avec élévation de privilèges, puis sélectionnez Continuer. Si la fenêtre Contrôle de compte dʼutilisateur ne sʼaffiche pas, passez à l’étape suivante.
  4. Tapez le chemin dʼaccès complet du fichier .msp pour la mise à jour de sécurité, puis appuyez sur Entrée.
  5. Après lʼinstallation de la mise à jour, redémarrez le serveur.

Vérifiez si vous pouvez désormais accéder à OWA et à ECP sur le serveur sans message d’erreur.

Si le message d’erreur ECP continue de s’afficher, procédez comme suit :

  1. Démarrez le Gestionnaire IIS sur le serveur.

  2. Accédez au site web Exchange principal>Répertoire virtuel ECP.

  3. Sélectionnez Paramètres de l’application>BinsearchFolder.

  4. Vérifiez les chemins d’accès aux répertoires Exchange affichés. Ils peuvent être similaires aux chemins suivants :

    %ExchangeInstallDir%bin ;
    %ExchangeInstallDir%bin\CmdletExtensionAgents ;
    %ExchangeInstallDir%ClientAccess\Owa\bin

  5. Remplacez les chemins d’accès par les chemins suivants :

    C :\Program Files\Microsoft\Exchange Server\V15\bin ;
    C :\Program Files\Microsoft\Exchange Server\V15\bin\CmdletExtensionAgents ;
    C :\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Owa\bin

    Remarque Les chemins d’accès doivent pointer vers l’emplacement d’installation d’Exchange Server. Les exemples suivants supposent que le programme est installé sur le lecteur C et que la version est Microsoft Exchange Server 2013. En cas d’installation sur un autre lecteur du serveur ou d’utilisation d’une autre version, telle que Microsoft Exchange Server 2010, utilisez les informations de chemin d’accès et de version correspondant à votre installation.

  6. Accédez à un dossier qui inclut les scripts Exchange Server. Par défaut, les scripts se trouvent dans le chemin d’accès suivant pour Exchange Server 2013 :

    C:\Program Files\Microsoft\Exchange Server\v15\Bin

    Remarque Pour Exchange Server 2010, les scripts sont situés dans le dossier V14.

  7. Démarrez l’environnement de ligne de commande Exchange Management Shell en tant qu’administrateur, puis exécutez les scripts suivants : .\UpdateCas.ps1 et .\UpdateConfigFiles.ps1.

  8. Quittez l’environnement de ligne de commande Exchange Management Shell, puis ouvrez une fenêtre d’invite de commandes en tant qu’administrateur.

  9. Exécutez iisreset.

  10. Redémarrez le serveur, puis vérifiez qu’aucun message d’erreur ne s’affiche quand vous accédez à ECP.