Conflit d’adresse proxy lors de l’ajout d’une adresse e-mail dans Exchange Online
Symptômes
Lorsque vous essayez d’attribuer une adresse proxy à un destinataire de courrier nouveau ou existant dans Exchange Online, vous recevez un message d’erreur qui ressemble à l’un des exemples suivants.
Erreur 1
L’adresse proxy « SMTP :<adresse> SMTP en conflit » est déjà utilisée par «< domain.prod.outlook.com/Microsoft> Exchange Hosted Organizations/contoso.onmicrosoft.com/<forest> ». Choisissez une autre adresse proxy.
Erreur 2
Un appel Microsoft Entra ID a été effectué pour maintenir la synchronisation de l’objet entre Microsoft Entra ID et Exchange Online. Toutefois, elle a échoué. Message d’erreur détaillé : Un autre objet avec la même valeur pour la propriété proxyAddresses existe déjà. ConflictingObject : PublicFolder_<GUID>.
Un utilisateur de messagerie, une boîte aux lettres utilisateur, une boîte aux lettres partagée, un groupe de distribution, un groupe Microsoft 365 et un dossier public à extension messagerie (MEPF) sont des exemples de destinataires de courrier.
Cause
Cause 1
Le premier message d’erreur se produit si un objet à extension messagerie dans Exchange Online utilise l’adresse proxy que vous souhaitez attribuer.
Cause 2
Le deuxième message d’erreur se produit si un objet MEPF qui existe uniquement dans Microsoft Entra ID utilise l’adresse proxy que vous souhaitez attribuer.
Résolution
La résolution de la première erreur consiste à case activée et à supprimer toute adresse proxy en conflit dans Exchange Online.
La résolution de la deuxième erreur consiste à case activée et à supprimer toute adresse proxy en conflit dans Exchange Online et à case activée pour et supprimer toute adresse proxy en conflit dans Microsoft Entra ID.
Utilisez la résolution appropriée, en fonction du message d’erreur que vous recevez. Ensuite, essayez à nouveau d’attribuer l’adresse proxy.
Rechercher et supprimer toute adresse proxy en conflit dans Exchange Online
Suivez ces étapes pour rechercher des objets à extension messagerie existants dans Exchange Online qui utilisent l’adresse proxy en conflit.
Pour répertorier tous les destinataires de courrier qui utilisent l’adresse SMTP en conflit, exécutez la commande suivante :
Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
Si vous ne connaissez pas l’adresse SMTP exacte, exécutez la commande suivante à la place :
Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<partial conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
Une adresse proxy ne peut être affectée qu’à un seul objet à la fois. Après avoir déterminé quel objet est en conflit, supprimez ou modifiez l’adresse proxy associée à cet objet.
Rechercher et supprimer toute adresse proxy en conflit dans Microsoft Entra ID
Importante
Cette résolution nécessite un serveur local sur lequel Microsoft Entra Connect est installé. Si votre infrastructure locale est désactivée, contactez Support Microsoft.
Suivez ces étapes pour case activée et supprimer de Microsoft Entra tous les MEPF qui utilisent l’adresse proxy en conflit. Ces étapes nécessitent un serveur local qui exécute Microsoft Entra Connect version 2.0 ou ultérieure.
Recherchez l’adresse proxy en conflit dans tous les MEPF locaux en exécutant la commande suivante dans exchange Management Shell (EMS) local :
Get-MailPublicFolder -ResultSize Unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"}
Pour chaque MEPF local identifié à l’étape 1, supprimez l’adresse SMTP en conflit en exécutant la commande suivante dans le service EMS local :
Set-MailPublicFolder -Identity <public folder name or GUID> -EmailAddresses @{remove="<conflicting SMTP address>"} -EmailAddressPolicyEnabled:$false
Cette étape supprime les conflits d’adresses proxy du côté local pour s’assurer qu’ils ne sont pas synchronisés avec Microsoft Entra ID ou Exchange Online.
Si vous avez supprimé une adresse SMTP en conflit d’un MEPF local à l’étape 2, attendez que la synchronisation planifiée suivante s’exécute sur le serveur Microsoft Entra Connect ou démarrez manuellement un cycle de synchronisation en exécutant la commande PowerShell suivante :
Start-ADSyncSyncCycle -PolicyType Delta
La synchronisation doit supprimer l’adresse SMTP en conflit de Microsoft Entra ID.
Si vous n’avez pas trouvé l’adresse SMTP en conflit dans un MEPF local, ou si la synchronisation n’a pas supprimé l’adresse SMTP en conflit de Microsoft Entra ID, recherchez Microsoft Entra ID pour les MEPF qui ont l’adresse SMTP en conflit. Pour rechercher des mePF dans Microsoft Entra ID, utilisez l’applet de commande PowerShell Get-ADSyncToolsAadObject sur le serveur Microsoft Entra Connect. La recherche ne respecte pas la casse. Incluez le préfixe « smtp : » lorsque vous spécifiez l’adresse SMTP.
$mailEnabledPublicFolders = Get-ADSyncToolsAadObject -SyncObjectType "PublicFolder" -Credential (Get-Credential)
$conflictingSmtpAddress = "smtp:<conflicting SMTP address>"
$mailEnabledPublicFolders | Where-Object {$_.ProxyAddresses -icontains $conflictingSmtpAddress} | Select SourceAnchor
Les résultats de la recherche fournissent le SourceAnchor pour chaque MEPF qui répond aux critères de recherche.
Pour chaque MEPF identifié à l’étape 4, supprimez le MEPF de Microsoft Entra ID à l’aide de l’applet de commande Remove-ADSyncToolsAadObject. Fournissez la
SourceAnchor
valeur du MEPF au format Base64.$conflictingSourceAnchor= "SourceAnchor value"
Remove-ADSyncToolsAadObject -SourceAnchor $conflictingSourceAnchor -SyncObjectType "PublicFolder" -Credentials (Get-Credential)
Pour obtenir un exemple d’utilisation d’applet de commande, consultez Remove-ADSyncToolsAadObject , exemple 2.
Réexécutez la recherche Microsoft Entra ID de l’étape 4. Cette fois, les résultats de la recherche ne doivent pas renvoyer de MEPF.
Commentaires
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