Un programme Office est lent ou peut cesser de répondre (blocage) lorsque vous ouvrez un fichier à partir d’un emplacement réseau

Symptômes

Lorsque vous essayez d’ouvrir un fichier à partir d’un emplacement réseau dans l’un des programmes Microsoft Office tels que PowerPoint 2003, Excel 2003, Publisher 2003 ou une version ultérieure, le programme Office peut fonctionner très lentement ou sembler ne plus répondre (blocage).

Cause

Ce comportement peut se produire si la connexion à l’emplacement réseau est perdue au moment où votre programme Office ouvre le fichier.

Solution de contournement

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, consultez l’article Comment sauvegarder et restaurer le Registre dans Windows.

Pour contourner ce problème, ajoutez la valeur EnableShellDataCaching au Registre Microsoft Windows. Pour cela, procédez comme suit :

  1. Fermez vos programmes Office.

  2. Cliquez sur Démarrer, puis sur Exécuter.

  3. Dans la zone Ouvrir, saisissez regedit, puis cliquez sur OK.

  4. Recherchez puis sélectionnez l’une des clés de Registre suivantes selon votre version dʼOffice :

    • Microsoft 365 Apps, Office LTSC 2021, Office 2019 et Office 2016 :

      HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Open Find

    • Office 2013 :

      HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Open Find

    • Office 2010 :

      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Open Find

    • Office 2007 :

      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find

    • Office 2003 :

      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find

  5. Une fois la clé spécifiée à l’étape 4 sélectionnée, pointez sur Nouveau dans le menu Édition, puis cliquez sur Valeur DWORD.

  6. Saisissez EnableShellDataCaching, puis appuyez sur Entrée.

  7. Cliquez avec le bouton droit sur EnableShellDataCaching, puis cliquez sur Modifier.

  8. Dans la zone Données de la valeur, tapez 1, puis cliquez sur OK.

    Remarque

    Tout nombre non nul dans le champ Données de la valeur active la mise en cache. Un nombre nul ou un champ laissé vide (par défaut) désactive la mise en cache.

  9. Dans le menu Fichier, cliquez sur Quitter pour fermer l’Éditeur du Registre.

Le problème est-il résolu ?

Vérifiez si le problème est résolu. Si c’est le cas, vous n’avez plus besoin de cette section. Sinon, vous pouvez contacter le support technique.

Informations supplémentaires

Cette situation peut se produire lorsque vous cliquez sur Ouvrir dans la boîte de dialogue Ouvrir (dans le menu Fichier, cliquez sur Ouvrir) pour ouvrir un fichier à partir d’un emplacement réseau (par exemple, un serveur réseau). Au cours du processus d’ouverture du fichier, vous perdez votre connexion réseau ou l’emplacement réseau qui contient le fichier que vous essayez d’ouvrir ne fonctionne plus. Au cours du processus d’ouverture du fichier, votre programme Office tente d’ajoute le nom et le chemin dʼaccès du fichier que vous essayez d’ouvrir à la liste des fichiers récents de Windows. Étant donné que l’emplacement réseau (chemin d’accès) n’existe pas actuellement, le programme Office peut s’exécuter lentement et sembler ne plus répondre (blocage).

Remarque

Cette situation peut également se produire si votre connexion à votre réseau est lente, car votre programme Office doit effectuer plusieurs requêtes sur le réseau pour obtenir les informations correctes sur le fichier.