Un élément avec la même clé a déjà été ajouté lors de la création d’un flux de travail dans Microsoft Dynamics 365
Cet article fournit une solution à une erreur qui se produit lorsque vous créez un workflow existant ou modifiez-le dans Microsoft Dynamics 365.
S’applique à : Microsoft Dynamics CRM
Numéro de base de connaissances d’origine : 4053915
Symptômes
Lors de la création ou de la modification d’un flux de travail existant dans Microsoft Dynamics 365, l’erreur peut s’afficher :
« Un élément avec la même clé a déjà été ajouté ».
La sélection du bouton Télécharger le journal affiche les informations suivantes :
Exception non gérée : System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]] : System.ArgumentException : Un élément avec la même clé a déjà été ajouté. Détail:
<OrganizationServiceFault xmlns :i="https://www.w3.org/2001/XMLSchema-instance
» xmlns="https://schemas.microsoft.com/xrm/2011/Contracts
»>
<ActivityId>xxx</ActivityId>
<ErrorCode-2147220970></ErrorCode>
<ErrorDetails xmlns :d2p1="https://schemas.datacontract.org/2004/07/System.Collections.Generic
» />
<Message>System.ArgumentException : un élément avec la même clé a déjà été ajouté.</Message>
<Timestamp>2017-11-08T20:52:35.6280057Z</Timestamp>
<ExceptionRetriable>false</ExceptionRetriable>
<ExceptionSource i :nil="true » />
<InnerFault i :nil="true » />
<OriginalException i :nil="true » />
<TraceText i :nil="true » />
</OrganizationServiceFault>
Si le suivi de la plateforme a été activé, vous verrez les erreurs suivantes enregistrées dans la trace.
Rapport d’erreurs MSCRM :
Erreur : un élément avec la même clé a déjà été ajouté.
Message d’erreur : un élément avec la même clé a déjà été ajouté.
Fichier source : Non disponible
Numéro de ligne : Non disponible
URL de requête :https://CrmOrgName.dynamics.com/AppWebServices/Workflow.asmx
Informations de trace de pile : [ArgumentException : un élément avec la même clé a déjà été ajouté.]
sur System.ThrowHelper.ThrowArgumentException(ressource ExceptionResource)
sur System.Collections.Generic.Dictionary'2.Insert(TKey key, TValue value, Boolean add)
sur Microsoft.Crm.Application.Components.UI.OptionGroup.AddItem(String text, String value, ListDictionary expandos)
sur Microsoft.Crm.Application.Controls.CreateStepControl.RenderEntityList(Writer HtmlTextWriter, StepControlType stepType, String onChange)
sur Microsoft.Crm.Application.Controls.StepBaseControl.RenderEntity(Writer HtmlTextWriter, StepControlType stepType, String onChange)
sur Microsoft.Crm.Application.Controls.CreateStepControl.Render(Writer HtmlTextWriter)
sur System.Web.UI.Control.RenderControlInternal(Writer HtmlTextWriter, adaptateur ControlAdapter)
chez Microsoft.Crm.Application.Controls.CompositeStepBaseControl.RenderChildSteps(Enregistreur HtmlTextWriter)
sur Microsoft.Crm.Application.Controls.WorkflowStepControl.Render(Writer HtmlTextWriter)
sur System.Web.UI.Control.RenderControlInternal(Writer HtmlTextWriter, adaptateur ControlAdapter)
sur Microsoft.Crm.Application.WebServices.WorkflowWebService.RenderWorkflow(WorkflowStep workflowStep, Boolean bSave, String parentStepId, String rendererTypeCode)
sur Microsoft.Crm.Application.WebServices.WorkflowWebService.RenderWorkflow(WorkflowStep workflowStep, String parentStepId, String rendererTypeCode)
sur Microsoft.Crm.Application.WebServices.WorkflowWebService.AddCreateEntityStep(String parentId, String entityId, String descriptionXml, String parentStepId, String rendererTypeCode)
En outre, vous pouvez également voir le message suivant.
MSCRM :ASSERTEX - ENTITY Singular LOCALIZED NAME NOT FOUND : logical name = 'msdyn_orginsightsuserdashboarddefinition' LANGUAGE ID = 1033
Cause
L’une des causes possibles de cette erreur est avec une convention d’affectation de noms d’entité dans les personnalisations. Pour cette erreur particulière, reportez-vous au nom de l’attribut répertorié dans la MSCRM:ASSERTEX
partie de l’erreur. Voir ci-dessous :
MSCRM :ASSERTEX - ENTITY Singular LOCALIZED NAME NOT FOUND : logical name = 'msdyn_orginsightsuserdashboarddefinition' LANGUAGE ID = 1033
Le problème persiste avec l’entité qui contient l’attribut msdyn_orginsightsuserdashboarddefinition
. Vous devez rechercher cet attribut dans les personnalisations De Microsoft Dynamics 365.
L’entité problématique est facile à trouver dans les personnalisations, car elle est normalement répertoriée en haut des entités sans nom répertorié. Consultez la capture d’écran ci-dessous :
Résolution
Pour résoudre cette erreur, vous devez donner à l’entité que vous avez située dans la section Cause un nom complet ainsi qu’un nom plural.
Ouvrez le client web Microsoft Dynamics 365 en tant qu’administrateur D365.
Ensuite, sélectionnez Paramètres, Personnalisations, puis Personnalisez le système.
Une fois la fenêtre de personnalisation ouverte, développez Entités.
Sélectionnez l’entité en haut sans nom complet répertorié.
Dans le volet de fenêtre de droite, donnez à l’entité un nom complet et un nom plural. Reportez-vous à la capture d’écran ci-dessous.
Après avoir nommé l’entité, sélectionnez Enregistrer , puis Publier.
Enfin, revenez à votre éditeur de flux de travail et essayez de créer un flux de travail ou de modifier un flux de travail existant. Il réussira maintenant.