Échec des règles de création d’enregistrements automatiques lorsque l’expéditeur de l’e-mail est un contact et un utilisateur dans Microsoft Dynamics CRM
Cet article fournit une résolution pour le contact parent ou une erreur de compte qui se produit lorsque les règles de création d’enregistrement automatique échouent.
S’applique à : Microsoft Dynamics CRM 2015
Numéro de base de connaissances d’origine : 3094208
Symptômes
Les règles de création d’enregistrement automatique échouent lorsque l’expéditeur de l’e-mail est un contact et un utilisateur dans Microsoft Dynamics CRM. Lorsque vous ouvrez le travail système de l’élément de règle, vous verrez si l’erreur suivante échoue :
Vous devez spécifier un contact parent ou un compte.
Cause
Il s’agit d’un problème connu et est planifié pour être résolu dans une mise à jour Microsoft Dynamics CRM Online de septembre.
Résolution
Une fois que ce correctif a été appliqué à l’organisation Microsoft Dynamics CRM Online, il sera nécessaire de désactiver la règle de création d’enregistrement automatique, de supprimer l’étape de création de cas dans l’élément de règle et de recréer l’étape de création de cas. Cette opération doit être effectuée, car le correctif inclut de nouvelles slugs de valeur dynamique à créer dans les champs Client et Contact prêtes à l’emploi. Pour ce faire :
- Accédez aux règles de création et de mise à jour automatiques de gestion des enregistrements de gestion des>paramètres.>
- Sélectionnez la coche en regard de la règle, puis sélectionnez Désactiver.
- Ensuite, ouvrez la règle de création d’enregistrement automatique.
- Sélectionnez cette option pour ouvrir l’élément de règle spécifié.
- Sous Actions, sélectionnez l’étape Créer un cas , puis sélectionnez Supprimer cette étape. Enregistrez le formulaire.
- Rajoutez l’action pour créer un cas.
- Sélectionnez Définir les propriétés et rajouter les mappages personnalisés. Les champs Client et Contact prêtes à l’emploi sont automatiquement renseignés sur {null(Propriétés du canal)}. Cette valeur doit rester, afin que la résolution e-mail soit correctement corrélée au contact ou au compte. Si cette valeur est modifiée, elle ne peut pas être réinitialisée manuellement et l’étape Créer une casse doit être supprimée et recréée.
- Enregistrez le formulaire,
- Réactivez la règle de création d’enregistrement automatique.
Plus d’informations
La conception actuelle des règles de création d’enregistrements automatiques ne résout pas l’expéditeur d’un e-mail s’il existe uniquement en tant qu’utilisateur dans Microsoft Dynamics CRM. Il doit également exister en tant que contact ou compte et peut être créé automatiquement en tant que contact lorsqu’il est reçu. Pour créer automatiquement l’expéditeur de l’e-mail en tant que contact, cochez la case Créer des enregistrements pour l’e-mail à partir d’expéditeurs inconnus dans la règle de création automatique d’enregistrements. Si cette zone n’est pas marquée, l’adresse e-mail n’est pas résolue et la règle ne sera pas déclenchée.