Le système se bloque lorsque vous ajoutez un compte qui exécute CRMAppPool en tant qu’utilisateur Microsoft Dynamics CRM
Cet article fournit une résolution du problème d’incident système qui se produit lorsque vous ajoutez un compte qui exécute CRMAppPool en tant qu’utilisateur Microsoft Dynamics CRM.
S’applique à : Microsoft Dynamics CRM 2011
Numéro de base de connaissances d’origine : 2500917
Symptômes
Lorsque vous ajoutez un compte qui exécute CRMAppPool en tant qu’utilisateur Microsoft Dynamics CRM, le système se bloque. En outre, vous pouvez recevoir des erreurs qui ressemblent à ce qui suit :
SecLib::RetrievePrivilegeForUser en échec - aucun rôle attribué à l’utilisateur. Hr retourné = -2147209463, Utilisateur : [userid]
Cause
Par défaut, lorsqu’un utilisateur Microsoft Dynamics CRM est créé dans Microsoft Dynamics CRM, l’utilisateur n’a aucun rôle de sécurité. Étant donné que le compte de service Microsoft Dynamics CRM est mappé avec l’utilisateur nouvellement créé, le compte de service Microsoft Dynamics CRM ne peut rien utiliser. Par conséquent, le système se bloque.
Ce comportement est normal. Le fait de rendre le compte qui exécute CRMAppPool dans un utilisateur Microsoft Dynamics CRM n’est pas pris en charge.
Résolution
Conservez le compte de service Microsoft Dynamics CRM en tant que compte de service dédié.
Plus d’informations
Vous trouverez plus d’informations dans la section Des autorisations d’identité du pool d’applications IIS services et CRMAppPool du Guide d’implémentation de Microsoft Dynamics CRM 2011.
Pour télécharger le guide, consultez le Guide d’implémentation de Microsoft Dynamics CRM 2011.