Impossible de se connecter à l’erreur de serveur distant générée par un plug-in personnalisé dans Microsoft Dynamics CRM
Cet article fournit une solution aux erreurs qui se produisent lorsqu’un plug-in personnalisé est déployé dans un environnement Microsoft Dynamics CRM qui exécute une action SOAP pour se connecter à une adresse ou à un service externe.
S’applique à : Microsoft Dynamics CRM 2011, Dynamics CRM 2013, Microsoft Dynamics CRM 2013 Service Pack 1, Dynamics CRM 2015
Numéro de la base de connaissances d’origine : 3080697
Symptômes
Considérez le scénario suivant : un plug-in personnalisé est déployé dans un environnement Microsoft Dynamics CRM qui exécute une action SOAP pour se connecter à une adresse ou à un service externe. Le plug-in peut recevoir l’un des messages d’erreur suivants si un proxy réseau est requis pour la communication externe :
Impossible de se connecter au serveur distant
Erreur : aucun point de terminaison à l’écoute de l’adresse<> du service personnalisé n’a pu accepter le message. Cela est souvent dû à une adresse ou une action SOAP incorrecte. Pour plus d’informations, consultez InnerException, le cas échéant.
Cause
Le serveur d’applications Microsoft Dynamics CRM se trouve derrière un proxy réseau et le plug-in est configuré pour s’exécuter en mode d’isolation (sandbox). Dans ce scénario, le compte de service exécutant le service de bac à sable Microsoft Dynamics CRM n’avait pas accès via le proxy réseau.
Résolution
Procédez comme suit pour configurer le compte de service de bac à sable Microsoft Dynamics CRM afin qu’il utilise le proxy réseau :
- Connectez-vous au serveur d’applications Microsoft Dynamics CRM à l’aide du compte de service de bac à sable Microsoft Dynamics CRM.
- Ouvrez Internet Explorer.
- Accédez à Outils>Options> Internet Connections Paramètres>réseau.
- Mettez à jour les sections Utiliser un script de configuration automatique ou Serveur proxy selon la configuration de l’environnement local.
Informations supplémentaires
Lorsque le plug-in s’exécute en mode d’isolation, l’appel à l’adresse ou au service externe est effectué par le compte de service sandbox Microsoft Dynamics CRM. Ce compte peut accéder au service externe à partir du serveur Microsoft Dynamics CRM qui héberge le service bac à sable Microsoft Dynamics CRM.