Erreur « Vous n’avez pas de licence » lorsque vous configurez Microsoft Dynamics CRM pour Microsoft Office Outlook
Cet article fournit une résolution pour que vous n’ayez pas de licence pour utiliser l’erreur Microsoft Dynamics CRM Online qui peut se produire lorsque vous configurez Microsoft Dynamics CRM pour Microsoft Office Outlook.
S’applique à : Microsoft Dynamics CRM
Numéro de base de connaissances d’origine : 3091628
Symptômes
Lorsque vous essayez de configurer Microsoft Dynamics CRM pour Microsoft Office Outlook, vous recevez le message d’erreur suivant :
Vous n’avez pas de licence pour utiliser Microsoft Dynamics CRM Online. Contactez votre administrateur Office 365 pour attribuer une licence Microsoft Dynamics CRM à vous.
Cause
Votre compte d’utilisateur n’a pas reçu de licence Microsoft Dynamics CRM Online.
Note
Si vous disposez d’un abonnement Office 365 existant et que vous avez ajouté ultérieurement un abonnement Microsoft Dynamics CRM Online, une licence Microsoft Dynamics CRM Online n’est pas affectée automatiquement à votre enregistrement utilisateur. Si votre compte d’utilisateur a le rôle Administrateur général ou Administrateur de service, vous pouvez toujours vous connecter à l’application web Microsoft Dynamics CRM pour effectuer des actions administratives, mais ne peut pas créer d’enregistrements tels que comptes, contacts, prospects, etc. Vous devez disposer d’une licence Microsoft Dynamics CRM Online pour vous connecter correctement Microsoft Dynamics CRM pour Microsoft Office Outlook à votre instance Microsoft Dynamics CRM Online. Dans l’application web Microsoft Dynamics CRM Online, vous pouvez accéder aux utilisateurs de sécurité>des paramètres>et modifier l’affichage en utilisateurs d’accès administratif. Cette vue affiche les utilisateurs qui ont des rôles d’administrateur dans le portail Office 365, mais qui n’ont pas de licence Microsoft Dynamics CRM Online attribuée.
Résolution
Connectez-vous au portail Office 365 en tant qu’utilisateur disposant de privilèges d’administration et attribuez une licence Microsoft Dynamics CRM Online à votre compte d’utilisateur. L’opération peut prendre quelques minutes avant que les informations de licence ne se synchronisent d’Office 365 vers Microsoft Dynamics CRM Online.
Pour obtenir des instructions détaillées sur l’attribution d’une licence dans Office 365, consultez Ajouter des utilisateurs et attribuer des licences en même temps.
Plus d’informations
Lorsque vous sélectionnez Détails dans la boîte de dialogue d’erreur ou si vous affichez le fichier journal, l’erreur suivante s’affiche :
Heure| Erreur | Exception : l’utilisateur n’a pas reçu de licence sur Microsoft.Crm.Application.Outlook.Config.ServerInfo.RunServerDiagnostics()
sur Microsoft.Crm.Application.Outlook.Config.ServerInfo.LoadUserInfo(IClientAuthProvider'1 orgAuthProvider)
sur Microsoft.Crm.Application.Outlook.Config.ServerInfo.Initialize(Uri discoveryUri, OrganizationDetail selectedOrg, String displayName, Boolean isPrimary, IClientAuthProvider'1 authenticatedProvider)
sur Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadDataToServerInfo()
sur Microsoft.Crm.Application.Outlook.Config.ServerForm.<InitializeBackgroundWorkers>b__3(Expéditeur d’objet, DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
sur System.ComponentModel.BackgroundWorker.WorkerThreadStart(argument Object)