Erreur lorsque vous cliquez sur certains liens dans la page Centre de projets dans Business Portal for Microsoft Dynamics SL
Cet article vous aide à résoudre un problème dans lequel vous recevez des messages d’erreur lorsque vous cliquez sur certains liens dans la page Centre de projets dans Business Portal.
S’applique à : Microsoft Dynamics SL 2011
Numéro de la base de connaissances d’origine : 915315
Symptômes
Envisagez les scénarios suivants dans Business Portal pour Microsoft Dynamics SL et pour Microsoft Business Solutions - Solomon :
- Lorsque vous cliquez sur le lien Heure sous la page Centre de projets dans Business Portal, le message d’erreur suivant s’affiche :
Erreur lors de la récupération des informations sur l’employé du projet lors de l’entrée De temps
- Lorsque vous cliquez sur le lien Approbations de document sous la page Centre de projets dans Business Portal, vous recevez le message d’erreur suivant :
Erreur dans /Application, la ressource est introuvable dans l’approbation du temps et des dépenses
- Dans la page Centre de projet du portail d’entreprise, vous recevez le message d’erreur suivant dans le composant WebPart Communicator :
Erreur lors de la récupération des informations sur l’employé du projet : ERREUR
- Lorsque vous cliquez sur le lien Modifier ou Rejeter sous la page Approbations d’élément de ligne exécutive pour un élément de dépense, vous recevez le message d’erreur suivant :
Erreur ASP rencontrée dans : GRFUNCTION. ASP / IsModuleUnlocked Error #424 Object required
Cause
Ce problème se produit parce qu’un ID de back-office valide n’est pas attribué à un rôle.
Remarque
Dans le volet Gérer les utilisateurs du portail d’entreprise , la zone ID back office d’un rôle attribué à l’utilisateur du portail d’entreprise contient la valeur par défaut Non spécifié .
Résolution
Pour résoudre ce problème, affectez un ID de back-office valide au rôle qui n’a pas d’ID de back-office valide. Pour cela, procédez comme suit :
- Connectez-vous à Business Portal en tant qu’administrateur.
- Cliquez sur Paramètres du site, puis sur Gérer les utilisateurs du portail d’entreprise.
- Dans le composant WebPart Liste d’utilisateurs , sélectionnez l’ID d’utilisateur approprié.
- Dans le composant WebPart Propriétés de l’utilisateur , cliquez sur l’onglet Rôles .
- Affectez un ID de back-office valide au rôle qui n’a pas d’ID de back-office valide.
Le problème décrit dans la section Symptômes ne s’applique pas à Microsoft Dynamics SL 7.0.