Certains rapports Dynamics SL SSRS ne s’affichent pas dans les navigateurs non-Microsoft
Cet article fournit une solution à un problème où la section rapport ne s’affiche pas lorsque vous ouvrez des rapports SQL Server Reporting Services (SSRS) dans des navigateurs non-Microsoft.
S’applique à : Microsoft Dynamics SL 2011 Service Pack 2
Numéro de la base de connaissances d’origine : 2932603
Symptômes
Lorsque vous ouvrez certains rapports SSRS, tels que Analyste de projet et Dépenses, dans un navigateur autre qu’Internet Explorer, vous pouvez remarquer que la section paramètres s’affiche, mais que la section rapport ne s’affiche pas.
Cause
Il existe un problème avec les navigateurs non-Microsoft qui affichent le contenu.
Résolution
Pour permettre au serveur de rapports de fonctionner correctement avec les navigateurs non-Microsoft, ajoutez une pageLoad
fonction avec le code ci-dessous à la fin du fichier ReportingServices.js sur le SQL Server.
Pour les ordinateurs SQL Server 2012, ajoutez le code suivant à Program Files\Microsoft SQL Server\MSRS11. MSSQLSERVER\Reporting Services\ReportManager\js\ReportingServices.js :
function pageLoad()
{
var element = document.getElementById("ctl32_ctl09");
if (element)
{
element.style.overflow = "visible";
}
}
Pour les ordinateurs SQL Server 2008 R2, ajoutez le code suivant à Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportManager\js\ReportingServices.js :
function pageLoad()
{
var element = document.getElementById("ctl31_ctl09");
if (element)
{
element.style.overflow = "visible";
}
}