Les utilisateurs sont invités de façon inattendue à taper un mot de passe par une base de données authentifiée Windows dans Microsoft Dynamics SL 2011
Cet article fournit des méthodes pour résoudre le problème que les utilisateurs sont invités de manière inattendue à entrer un mot de passe lorsqu’ils se connectent à une base de données authentifiée Windows dans Microsoft Dynamics SL 2011 après une mise à niveau.
S’applique à : Microsoft Dynamics SL 2011
Numéro de base de connaissances d’origine : 2550383
Symptômes
Les utilisateurs sont invités à entrer un mot de passe lorsqu’ils se connectent à une base de données Authentifiée Windows dans Microsoft Dynamics SL 2011 une fois le système mis à niveau à partir d’une version antérieure de Microsoft Dynamics SL.
Cause
Ce comportement se produit parce qu’une nouvelle fonctionnalité a été ajoutée dans Microsoft Dynamics SL 2011 pour exiger éventuellement l’entrée d’un mot de passe lorsque les utilisateurs se connectent, même lorsque l’authentification Windows est utilisée. Lorsqu’une base de données qui a utilisé l’authentification SQL précédemment est mise à niveau, le mot de passe de chaque utilisateur est conservé et doit être entré lorsque l’utilisateur se connecte à Microsoft Dynamics SL 2011.
Résolution
Si vous ne souhaitez pas exiger l’entrée d’un mot de passe pour une base de données authentifiée Windows, supprimez la valeur de la zone Mot de passe de l’écran Maintenance utilisateur (95.260.00) pour tous les utilisateurs, à l’exception de l’utilisateur Sysadmin. Pour cela, appliquez l’une des méthodes suivantes :
Méthode 1
- Connectez-vous à Microsoft Dynamics SL en tant qu’utilisateur SYSADMIN.
- Sous le groupe de modules Administration, ouvrez l’écran Maintenance des utilisateurs (95.260.00).
- Sélectionnez un ID utilisateur dans la zone ID d’utilisateur .
- Supprimez la valeur de la zone de mot de passe .
- Enregistrez, puis répétez pour chaque utilisateur.
Méthode 2
Note
Avant de suivre les instructions de cette section, vérifiez que vous disposez d’une copie de sauvegarde complète de la base de données que vous pouvez restaurer si un problème se produit.
Déconnectez tous les utilisateurs de la base de données Microsoft Dynamics SL.
Exécutez l’instruction SQL suivante dans Microsoft SQL Server Management Studio sur votre base de données système Microsoft Dynamics SL 2011 pour supprimer les mots de passe pour tous les utilisateurs, à l’exception de Sysadmin :
update userrec set Password = '' where UserId not like ('SYSADMIN')
Plus d’informations
Pour plus d’informations, consultez la rubrique Microsoft Dynamics SL Login dans la section Référence de l’aide microsoft Dynamics SL 2011 ou du Guide de l’utilisateur.