Partager via


La valeur de pausedon est null lorsque l’état de l’instance de l’indicateur de performance clé SLA est en attente (suspendu)

Cet article fournit une résolution d’un problème où la pausedon propriété d’une instance de KPI de niveau de service est définie sur Null lorsque l’état de l’instance SLA est suspendu (suspendu).

Symptômes

Lorsque vous mettez à jour un cas, vous recevez le message d’erreur suivant :

Message d’exception : Une exception s’est produite dans l’action personnalisée de gestion SLAInstance : System.InvalidOperationException : l’objet Nullable doit avoir une valeur.

Cause

La pausedon propriété de l’instance d’indicateur de performance clé SLA est mise à jour sur null par le biais d’une logique personnalisée ou d’un flux de travail lorsque l’état de l’instance de L’indicateur de performance clé SLA est mis en attente (suspendu). Par conséquent, la valeur du pausedon fichier n’est pas remplie.

Résolution

Pour résoudre ce problème, vérifiez si une logique personnalisée ou un flux de travail est implémenté pour la transition de l’état de l’instance KPI SLA.

Si une logique ou un flux de travail personnalisé est implémenté pour mettre à jour l’état de l’instance de l’indicateur de performance clé SLA, désactivez la logique personnalisée ou le flux de travail et utilisez la fonctionnalité prête à l’emploi pour suspendre et reprendre l’état de l’instance de L’indicateur de performance clé SLA.