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401 Une exception non autorisée se produit dans Microsoft Dynamics 365 lors de l’utilisation de la synchronisation Server-Side

Cet article fournit une solution à une erreur qui se produit lorsque vous utilisez la synchronisation Server-Side dans Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de la base de connaissances d’origine : 3212785

Importante

Si vous utilisez Exchange Online et que cette erreur se produit après le 1er octobre 2022, cela peut être dû à la désactivation de l’authentification de base. Pour plus d’informations sur l’activation temporaire de l’authentification de base pendant une durée limitée, consultez Utilisation de l’authentification de base avec Exchange Online.

Symptômes

Lorsque vous utilisez la synchronisation Server-Side dans Dynamics 365, vous recevez l’une des erreurs suivantes :

  • Impossible d’envoyer le message électronique « Message de test ». Assurez-vous que les informations d’identification spécifiées dans le nom> de la boîte aux lettres <sont correctes et disposent des autorisations suffisantes pour envoyer des e-mails. Ensuite, activez la boîte aux lettres pour le traitement des e-mails.
  • Les rendez-vous, les contacts et les tâches ne peuvent pas être synchronisés. Assurez-vous que les informations d’identification spécifiées dans le nom> de la boîte aux lettres <sont correctes et disposent des autorisations suffisantes. Ensuite, activez la boîte aux lettres pour la synchronisation des rendez-vous, des contacts et des tâches.
  • Email ne peut pas être reçu pour la boîte aux lettres <Nom de> la boîte aux lettres. Assurez-vous que les informations d’identification spécifiées dans la boîte aux lettres sont correctes et disposent des autorisations suffisantes pour recevoir des messages électroniques. Ensuite, activez la boîte aux lettres pour le traitement des e-mails.

Le message inclut également le code d’erreur suivant :

code d’erreur du serveur Email : le serveur HTTP a renvoyé l’exception 401 Non autorisé.

Cause

Ces erreurs peuvent se produire pour l’une des raisons suivantes :

  1. L’adresse de messagerie de l’enregistrement de boîte aux lettres dans Dynamics 365 ne correspond pas à l’adresse de messagerie de la boîte aux lettres dans Exchange.

  2. Si vous utilisez Dynamics 365 (en ligne) avec Exchange Online, cette erreur peut se produire si vous utilisez un profil Exchange Server (hybride), même si la boîte aux lettres de l’utilisateur se trouve dans Exchange Online.

  3. Si vous utilisez Dynamics 365 avec Exchange Online, cette erreur peut se produire si l’utilisateur n’a pas de licence Exchange Online.

  4. Si vous utilisez Dynamics 365 (en ligne) avec Exchange Online, cette erreur peut se produire si votre abonnement Dynamics 365 n’est pas dans le même locataire Office 365 que votre abonnement Exchange Online. Lorsque vous utilisez un profil de serveur de messagerie Exchange Online, Dynamics 365 (en ligne) et Exchange Online doivent se trouver dans le même compte/locataire Office 365.

  5. Si vous utilisez Dynamics 365 (en ligne) avec Exchange local, cette erreur peut se produire si l’authentification de base n’est pas activée pour EWS (Exchange Web Services).

  6. L’utilisateur ou la boîte aux lettres qui avait été supprimé a été recréé ultérieurement à l’aide de la même adresse e-mail.

    Lorsque vous essayez de tester et d’activer la boîte aux lettres, vous pouvez voir que le message NoUserFoundWithGivenClaims est inclus dans le cadre d’une alerte de niveau d’erreur. Vous pouvez également voir une alerte dans laquelle la section détails indique « L’utilisateur n’existe pas dans le locataire avec l’ID d’utilisateur> ».<

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Vérifiez que l’adresse de messagerie de l’enregistrement de boîte aux lettres dans Dynamics 365 correspond à l’adresse de messagerie dans Exchange. L’erreur inclut un lien vers l’enregistrement de boîte aux lettres dans Dynamics 365. Vous pouvez utiliser ce lien pour vérifier rapidement le champ Adresse Email.

  2. Si vous utilisez Dynamics 365 (en ligne) avec Exchange Online, vérifiez que vous utilisez un profil de serveur de messagerie Exchange Online. Utilisez uniquement un profil Exchange Server (hybride) pour les utilisateurs qui ont des boîtes aux lettres dans Exchange en local.

  3. Si vous utilisez Dynamics 365 avec Exchange Online, vérifiez que l’utilisateur dispose d’une licence Exchange Online. Pour plus d’informations sur l’attribution de licences dans Office 365, consultez Ajouter des utilisateurs et attribuer des licences en même temps.

  4. Si vous utilisez Dynamics 365 (en ligne) avec Exchange Online, vérifiez que Dynamics 365 (en ligne) et Exchange Online se trouvent dans le même compte/locataire Office 365.

  5. Si vous utilisez Dynamics 365 (en ligne) avec Exchange en local, vérifiez que l’authentification de base est activée pour EWS (Exchange Web Services). Pour plus d’informations, consultez la section Prérequis de La connexion Dynamics 365 (en ligne) à Exchange Server (localement).

  6. Si l’utilisateur ou la boîte aux lettres qui avait été supprimé a été recréé ultérieurement à l’aide de la même adresse e-mail :

    1. Assurez-vous que l’utilisateur ou la boîte aux lettres existant précédemment a été supprimé définitivement. Par défaut, un utilisateur supprimé de Microsoft Entra ID peut avoir son compte restauré dans un délai de 30 jours. Pour plus d’informations, consultez Supprimer définitivement un utilisateur.
    2. Après avoir vérifié qu’aucun utilisateur ou boîte aux lettres n’utilise la même adresse e-mail, vous pouvez essayer de tester et réactiver la boîte aux lettres. Si vous recevez toujours le message d’erreur, le problème peut être dû au résultat de la mise en cache. L’effacement du cache peut prendre jusqu’à 72 heures. Si vous ne pouvez pas attendre 72 heures, contactez Support Microsoft.