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Cet article fournit une solution à un problème où les vérifications ne se chargent pas dans la fenêtre Chargement SafePay-Transactions dans Microsoft Dynamics GP.
S’applique à : Microsoft Dynamics GP
Numéro de base de connaissances d’origine : 2708664
Symptômes
Les chèques ne s'affichent pas dans la fenêtre de chargement SafePay-Transactions lorsque vous sélectionnez le bouton Charger/recharger les transactions.
Cause
Il existe plusieurs raisons pour lesquelles les vérifications peuvent ne pas remplir la fenêtre de chargement SafePay-Transactions, notamment :
- L'identifiant du carnet de chèques dans lequel le chèque est généré n'est pas lié à l'identifiant de chargement bancaire dans SafePay.
- La date de vérification ne se situe pas entre la date du dernier chargement et la date limite de chargement spécifiées dans la fenêtre de chargement SafePay-Transactions.
- La vérification a déjà été chargée dans un fichier SafePay.
- Les codes de transaction n’ont pas été définis dans le configurateur Safepay.
- Le client n’est pas inscrit pour le module Rapprochement bancaire.
- Le configurateur SafePay a un paramètre marqué pour omettre les vérifications commençant par des caractères alpha.
- Le préfixe DD a été supprimé du numéro du relevé de gains suivant dans la paie, donc le système traite tous les chèques comme des dépôts directs et ne les inclut pas dans le téléchargement SafePay.
Résolution
Méthode 1 : l’ID du checkbook n’est pas lié à l’ID de chargement bancaire dans SafePay.
Procédez comme suit pour vous assurer que l’identifiant du carnet de chèques est lié à l’identifiant de chargement bancaire que vous utilisez dans SafePay :
Sélectionnez Outils dans le menu Microsoft Dynamics GP, pointez sur Configurer, pointez sur Achat, puis sélectionnez Payables. Passez en revue ce qui est défini comme le chéquier par défaut pour les comptes à payer, puis sélectionnez OK pour fermer la fenêtre.
Note
Si vous définissez également un ID de checkbook par défaut au niveau du fournisseur, vous pouvez également vérifier l’ID de checkbook par défaut attribué aux fournisseurs.
Sélectionnez Outils dans le menu Microsoft Dynamics GP, pointez sur Routines, pointez sur Finances, pointez sur Paiement sécurisé, puis sélectionnez Charger la maintenance.
Sélectionnez l’identifiant de téléchargement bancaire utilisé, dans le menu déroulant.
Passez en revue les identifiants de carnet de chèques répertoriés. Si l’ID du chéquier souhaité n’est pas répertorié, sélectionnez Ajouter un chéquier pour sélectionner un ID de chéquier à lier à cet ID de téléversement bancaire.
Enregistrez vos modifications et testez à nouveau.
Méthode 2 - La date des chèques ne se trouve pas dans la plage de dates entre la Date de Dernier Chargement et la Date Limite de Chargement spécifiée dans la fenêtre de Chargement des Transactions SafePay.
Vérifiez qu’il existe des chèques émis entre la date de dernier téléchargement et la date limite de téléchargement utilisée dans la fenêtre Chargement SafePay-Transactions.
Notez la date d'émission d’un échantillon de chèque.
Dans la fenêtre Chargement safePay-Transactions, assurez-vous que cette date se situe entre la date de dernier chargement et la date de coupure de chargement.
Méthode 3 : les vérifications ont déjà été chargées dans un fichier SafePay.
Vérifiez si les chèques que vous essayez de charger ont déjà été chargés. Procédez comme suit pour passer en revue l’historique des transactions :
Sélectionnez Outils dans le menu Microsoft Dynamics GP, pointez sur Routines, pointez sur Financial, pointez sur Paiement sécurisé, puis sélectionnez Historique des transactions.
Entrez l’ID de chargement bancaire (auquel l’ID du chéquier est lié).
Utilisez les boutons de défilement à gauche et à droite pour parcourir tous les identifiants de téléchargement bancaire. Passez en revue les détails de la transaction en bas de la fenêtre pour voir si le ou les numéros de vérification que vous essayez de charger ont déjà été chargés.
Sélectionnez Charger en haut de la fenêtre Charger l’historique des transactions pour générer à nouveau le fichier SafePay pour l’ID de chargement sélectionné dans la fenêtre.
Méthode 4 : les codes de transaction n’ont pas été définis dans le configurateur Safepay.
Les codes de transaction doivent être obtenus à partir de la banque et entrés dans la fenêtre Entrée des codes dans la configuration safepay Configurator. Il s’agit de codes que la banque utilise pour distinguer les chèques, les vides et les paiements EFT les uns des autres dans le fichier. Le système remplace le code approprié entré dans le fichier Paiement sécurisé généré pour le champ Type de transaction mappé. Pour définir les codes de transaction dans le configurateur, procédez comme suit :
Ouvrez le fichier configurator. Pour ce faire, sélectionnez Outils sous Microsoft Dynamics GP, pointez sur Routines, pointez sur Financial, pointez sur Paiement sécurisé, puis sélectionnez Configurator.
Dans la fenêtre du configurateur de paiement sécurisé, sélectionnez l'ID de format bancaire que vous utilisez.
Sur la barre de menus supérieure, sélectionnez Codes d'entrée, puis sélectionnez Codes d'entrée de transaction. (Vous devez obtenir les codes que vous devez entrer auprès de votre banque avant de procéder à cette étape. Ou vous pouvez être en mesure de le dire en examinant le fichier d’importation bancaire.)
Dans la fenêtre Entrée des types de transactions :
Sélectionnez Vérifier le type de transaction et entrez le code correspondant à partir de la banque qui signifie vérifier.
Sélectionnez Void pour le type de transaction et entrez le code correspondant de la banque qui signifie void. Il existe également une option pour Voids Zero Amount. Marquez-la si vous souhaitez que le montant des transactions annulées soit 0,00 ou laissez-le non marqué pour avoir le montant d’origine répertorié sur la transaction annulée dans le fichier SafePay.
Sélectionnez EFT pour le type de transaction et entrez le code correspondant à partir de la banque, ce qui signifie EFT. Si la banque n’a pas de code spécifique pour EFT, entrez le même code que celui que vous avez entré pour le type Check, car de nombreuses banques considèrent simplement efTs et les vérifications comme étant le même type.
Sélectionnez ensuite Enregistrer puis fermez la fenêtre. Sélectionnez Enregistrer à nouveau dans la fenêtre Configurateur de paiement sécurisé et testez pour voir si la fenêtre de Chargement de paiement sécurisé s'affiche maintenant.
Méthode 5 : le client n’est pas inscrit pour le module Rapprochement bancaire.
SafePay tire de la table CM20200 dans le module de rapprochement bancaire. Par conséquent, le client doit être inscrit pour le rapprochement bancaire afin d’utiliser SafePay.
Option 1 : contactez votre partenaire pour examiner les modules auxquels le client est inscrit, ou pour acheter le module de rapprochement bancaire.
Option 2 : si la table SQL (CM20200) est vide, vous n’êtes probablement pas inscrit pour le rapprochement bancaire. Vous pouvez utiliser SQL Server Management Studio pour passer en revue la table SQL.
Méthode 6 : si les chèques ont un préfixe, ils peuvent être omis lors du chargement de la fenêtre de chargement des transactions Safepay en raison d’une case à cocher dans la configuration. Accédez au configurateur safepay, sélectionnez l’ID de format, sélectionnez Entrée de codes | Entrée des codes de transaction, puis sélectionnez Vérifications. Vérifiez que la case à cocher « Omettre les vérifications avec alphas » n’est pas marquée. S’il est marqué, les vérifications commençant par des caractères alpha ne chargent pas la fenêtre Chargement des transactions Safepay.
Méthode 7 : le préfixe DD a été supprimé du numéro de l’état des revenus suivant dans la paie, de sorte que le système traite tous les chèques comme des dépôts directs et ne les inclut pas dans le chargement Safepay.
La procédure stockée utilisée pour remplir la fenêtre de chargement des transactions SafePay examinera le préfixe affecté au numéro de la prochaine déclaration de revenus dans la paie, que vous utilisiez la paie américaine ou Dépôt Direct ou non. Le système compare toutes les vérifications au numéro du prochain relevé de bénéfices pour déterminer s’il s’agit d’un dépôt direct ou non. Par conséquent, si un utilisateur supprime le préfixe DD par défaut, le système traite toutes les vérifications comme des dépôts directs qui commencent par le même chiffre et ne les remplissent pas dans la fenêtre Chargement des transactions SafePay. Par exemple, si le numéro suivant du relevé des bénéfices pour les dépôts directs commence par 0, le système traite également toutes les vérifications qui commencent également par 0 comme dépôts directs et ne les incluent pas dans SafePay. Procédez comme suit pour passer en revue :
Sélectionnez Outils dans le menu Microsoft Dynamics GP, pointez sur Configuration, pointez sur Paie, puis sélectionnez Dépôt direct.
Assurez-vous que le préfixe DD se trouve au début du numéro de l’état de résultat suivant. Ajoutez le préfixe DD au début du numéro d’état de résultat suivant si nécessaire.
Sélectionnez OK pour fermer la fenêtre.
Note
La procédure stockée vérifiera le numéro du prochain relevé de salaires, que vous utilisiez la paie ou le dépôt direct.