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Cet article fournit une solution à un problème dans lequel la fenêtre Sélectionner des transactions bancaires n’affiche aucune transaction lorsque vous essayez de rapprocher votre carnet de chèques dans Le rapprochement bancaire.
S’applique à : Microsoft Dynamics GP, Microsoft Dynamics SL Bank Reconciliation
Numéro de base de connaissances d’origine : 860314
Symptômes
La fenêtre Sélection des transactions bancaires n’affiche aucune transaction lorsque vous essayez de rapprocher votre chéquier lors du rapprochement bancaire.
Cause
Ce problème peut se produire pour l’une des raisons suivantes :
- Le rapprochement bancaire n'est pas inscrit ou marqué dans la fenêtre d'enregistrement.
- La colonne Réconcilier le nombre (RECONUM) dans la table CM20200 ne correspond pas à la colonne Rapprochement des nombres (RECONUM) dans la table CM20500.
- Les transactions ont déjà été rapprochées. Les transactions spécifiées auront désormais une valeur de 1, indiquant que la transaction est déjà réconciliée dans Microsoft Dynamics GP. Par conséquent, il ne sera plus extrait dans la fenêtre Sélectionner les transactions bancaires lorsque vous effectuez la rapprochement en sélectionnant Transactions, en pointant sur Finances, en sélectionnant Rapprochement des relevés bancaires, puis en sélectionnant Transactions.
- Les dossiers étaient dans un processus de rapprochement endommagé.
- L’ordre/classement de tri SQL n’est pas pris en charge avec Microsoft Dynamics GP.
Résolution
Pour résoudre ce problème, suivez l’une des méthodes ci-dessous :
Méthode 1
- Vérifiez que le rapprochement bancaire est enregistré et marqué dans la fenêtre d'enregistrement. Pour ce faire, sélectionnez Outils sous Microsoft Dynamics GP, configurez, sélectionnez Système, puis Inscription. Faites défiler vers le bas dans la fenêtre Inscription et vérifiez que le rapprochement bancaire est répertorié et que la case à cocher est marquée.
Méthode 2
Vérifiez que les transactions n’ont pas encore été rapprochées. Pour ce faire, procédez comme suit :
- Sélectionnez Enquête, Sélectionnez Financial, puis Checkbook Register.
- Tapez ou sélectionnez l'identifiant de carnet de chèques approprié.
- Dans le menu Affichage , sélectionnez par Date, puis sélectionnez le champ À partir .
- Définissez le champ From pour avoir une valeur zéro, puis tapez la date utilisée comme date de fin d’relevé bancaire ou date de coupure dans la fenêtre Rapprochement des relevés bancaires.
- Sélectionnez Redisplay.
- Sélectionnez Afficher les détails pour développer les informations fournies et vérifier que la colonne réconciliée est définie sur Oui. Si les transactions ne sont pas encore réconciliées et que vous effectuez la réconciliation, le champ RECONUM de la table CM20500 peut expliquer pourquoi aucune transaction n'apparaît dans la fenêtre Sélectionner des transactions bancaires.
Dans Microsoft Dynamics GP, une valeur RECONUM spécifique est affectée au checkbook lorsque des informations sont entrées dans la fenêtre Rapprochement des relevés bancaires. Lorsqu’une transaction est marquée dans la fenêtre Select Bank Transactions pour ce checkbook, la colonne RECONUM de cette transaction dans la table CM20200 est remplie avec cette même valeur RECONUM qui se trouve dans la table CM20500. Si les valeurs RECONUM dans la table CM20200 et la table CM20500 ne sont pas identiques, aucune transaction n’est générée dans la fenêtre Sélectionner les transactions bancaires pendant le processus de rapprochement.
Méthode 3
Vérifiez que la valeur du numéro de rapprochement correspond entre les tables. Pour ce faire, procédez comme suit :
Ouvrez SQL. Pour ce faire, effectuez l’une des étapes suivantes :
- Pour SQL Server 2005, ouvrez SQL Server Management Studio, sélectionnez Nouvelle requête, puis sélectionnez la base de données d’entreprise appropriée.
- Pour SQL Server 2008, ouvrez SQL Server Management Studio, sélectionnez Nouvelle requête, puis sélectionnez la base de données d’entreprise appropriée.
Vérifiez que le champ RECONUM a la même valeur dans la table CM20200 et la table CM20500 en exécutant les instructions SQL suivantes.
SELECT MAX(RECONUM) FROM CM20200 WHERE CHEKBKID = '**XXX**' SELECT MAX(RECONUM) FROM CM20500 WHERE CHEKBKID = '**XXX**' SELECT RECONUM FROM CM20500 WHERE CHEKBKID = '**XXX**' and RECONUM = (select MAX(RECONUM) from CM20200 where CHEKBKID = '**XXX**')Note
Dans ces déclarations, le placeholder XXX représente l’ID du chéquier.
Exécutez également ce script pour vérifier s'il existe une tâche de réconciliation endommagée ou bloquée pour l'identifiant du carnet de chèques :
select distinct (RECONUM) from CM20200 where RECONUM not in (select RECONUM from CM20500) and RECONUM <> '0.00000' and CHEKBKID = 'xxx'--- où xxx est l'ID du carnet de chèques dont vous avez besoin
-
Note
Résultats générés à partir de la requête SQL à l’étape 2.
Vérifiez que l’instruction suivante est vraie :
La valeur maximale du champ RECONUM de la table CM20200 générée à partir de la première instruction de l’étape 2 est un nombre inférieur à la valeur maximale du champ RECONUM de la table CM20500 générée à partir de la deuxième instruction décrite dans la même étape.
Le résultat généré par la troisième instruction décrite à l’étape 3 est revenu avec des résultats vides. Si les instructions de l’étape précédente sont vérifiées comme vraies, exécutez la requête SQL suivante pour résoudre le problème :
update CM20500 set RECONUM = (select MAX(RECONUM) from CM20200 where CHEKBKID = '**XXX**') where RECONUM = (select MAX(RECONUM) from CM20500 where CHEKBKID = '**XXX**')Note
Dans cette requête, le champ XXX représente l’identifiant du chèquier.
Connectez-vous à Microsoft Dynamics GP. Sélectionnez Transactions, sélectionnez Finances, puis Rapprochement des relevés bancaires. Sélectionnez l’ID du checkbook, puis sélectionnez Transactions. Vérifiez que les transactions s’affichent maintenant correctement dans la fenêtre Sélectionner des transactions bancaires.
Méthode 4 : Vérifier les liens
Effectuez d’abord une sauvegarde ou faites-la dans une entreprise de test. Sous Microsoft Dynamics GP, pointez sur Maintenance et sélectionnez Vérifier les liens. Sélectionnez la série financière. Dans la liste Tables logiques, sélectionnez Transaction CM, puis sélectionnez Insérer afin qu’elle s’affiche sous Tables sélectionnées. Cliquez sur OK. Passez en revue le rapport du journal des erreurs et, si vous êtes d’accord avec les actions répertoriées, vous pouvez les appliquer dans l’entreprise en production.
Vérifiez maintenant si les transactions s’affichent dans la fenêtre rapprochement bancaire.
Méthode 5 : Classement SQL
Exécutez le script ci-dessous dans SQL Server Management Studio pour vérifier l’ordre de tri SQL et le classement SQL. Dans les résultats, recherchez la ligne de l’entreprise avec laquelle vous travaillez et faites glisser le champ État pour pouvoir lire les données dans ce champ. Vérifiez que le classement (Collation) et l'« SQLSortOrder » sont une version prise en charge. (L’ordre de tri SQL doit être 50 ou 52). La fenêtre peut ne pas s'afficher si vous n’êtes pas dans une version prise en charge.
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