Correction des mises à jour d’Exchange Server ayant échoué

Si vous rencontrez une erreur lorsque vous essayez d’installer une mise à jour cumulative (CU) ou une mise à jour de sécurité (SU) pour Microsoft Exchange Server, sélectionnez la description d’erreur applicable dans la liste en haut de l’article, puis suivez la résolution appropriée.

Erreurs HTTP 500 dans Outlook sur le web ou ECP

Problème

Les erreurs HTTP 500 se produisent dans Outlook sur le web ou le Panneau de configuration Exchange (ECP) ou dans les deux applications, une fois les mises à jour installées. Une fois que vous avez fourni des informations d’identification pour vous connecter à Outlook sur le web ou ecP, le processus de connexion échoue et génère le message d’erreur suivant :

Impossible de charger le fichier ou l’assembly Microsoft.Exchange.Common, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' ou l’une de ses dépendances. Le système ne peut pas trouver le fichier spécifié.

Résolution

Réinstallez la mise à jour de sécurité à l’invite de commandes avec élévation de privilèges :

  1. Sélectionnez Démarrer, puis tapez cmd.

  2. Cliquez avec le bouton droit sur Invite de commandes dans les résultats de la recherche, puis sélectionnez Exécuter en tant qu’administrateur.

  3. Si la fenêtre Contrôle de compte d’utilisateur s’affiche, sélectionnez l’option permettant d’ouvrir une fenêtre d’invite de commandes avec élévation de privilèges, puis sélectionnez Continuer. Si la fenêtre UAC n’apparaît pas, passez à l’étape suivante.

  4. Tapez le chemin complet du fichier .msp pour la mise à jour de sécurité, puis appuyez sur Entrée.

  5. Une fois la mise à jour installée, redémarrez le serveur.

Pour plus d’informations, consultez Outlook sur le web ou ECP cesse de fonctionner après l’installation d’une mise à jour de sécurité.

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Erreurs HTTP 400 dans Outlook sur le web et ecP et erreur de connexion dans EMS

Problème

Les erreurs HTTP 400 peuvent se produire dans Outlook sur le web et le Panneau de configuration Exchange (ECP) après l’installation des mises à jour. Une fois que vous avez fourni des informations d’identification pour vous connecter à Outlook sur le web ou ecP, le processus de connexion échoue et génère le message d’erreur suivant :

HTTP 400 - requête incorrecte
Impossible de sérialiser le contexte

En outre, lorsque vous démarrez Exchange Management Shell (EMS), vous recevez le message d’erreur suivant :

ErrorCode : -2144108477
TransportMessage : le service WS-Management ne peut pas traiter la requête, car le code XML n’est pas valide.
ErrorRecord : La connexion au serveur distant exchange.contoso.com a échoué avec le message d’erreur suivant : Pour plus d’informations, consultez la rubrique d’aide about_Remote_Troubleshooting.

La cause

Ce problème se produit si le nom d’utilisateur se termine par un signe $dollar. Par exemple, le nom d’utilisateur admin$.

Résolution

Supprimez le signe $ dollar du nom d’utilisateur ou utilisez un autre compte administratif qui ne se termine pas par un $.

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Images manquantes dans ECP

Problème

Une fois que vous avez installé la su, Outlook sur le web ou le Panneau de configuration Exchange (ECP) n’affiche pas d’images.

La cause

Ce problème se produit si la su n’est pas installée correctement.

Résolution

Désinstallez et réinstallez le fichier .msp en exécutant la mise à jour à l’invite de commandes d’administration. Ensuite, redémarrez le serveur une fois l’installation terminée.

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Page vierge dans EAC ou Outlook sur le web

Problème

Une page vierge s’affiche lorsque vous vous connectez au Centre d’administration Exchange (EAC) ou Outlook sur le web. Lorsque ce problème se produit, l’événement 15021 peut être journalisé.

La cause

Ce problème se produit si la liaison SSL sur le point de terminaison 0.0.0.0:444 présente un ou plusieurs des problèmes suivants :

  • La liaison est installée de manière incorrecte
  • La liaison n’a pas de certificat assigné.
  • Le document contient des informations incorrectes.

Résolution

Suivez ces étapes :

  1. Ouvrez Internet Information Services (IIS).

  2. Développez Sites, sélectionnez Site web par défaut, puis sélectionnez Liaisons dans le volet Actions .

  3. Dans la boîte de dialogue Liaisons de site, ouvrez la liaison pour la valeur Typehttps et la valeur Port443.

  4. Vérifiez si un certificat SSL valide est spécifié pour le site web par défaut. Si ce n’est pas le cas, spécifiez un certificat SSL valide, tel que Microsoft Exchange, puis sélectionnez OK.

    Capture d’écran montrant le champ certificat SSL dans la fenêtre Modifier la liaison de site dans le Gestionnaire IIS.

  5. Exécutez la commande suivante dans une fenêtre PowerShell avec élévation de privilèges pour redémarrer IIS :

    Restart-Service WAS,W3SVC
    
  6. Sur le serveur de courriels, effectuez les étapes 1 à 5 pour le site Exchange Back End.

    Capture d’écran montrant le champ certificat SSL dans la fenêtre Modifier la liaison de site pour le site principal Exchange dans le Gestionnaire IIS.

Pour plus d’informations, voir Vous obtenez une page vide après la connexion dans EAC ou Outlook sur le web.

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Impossible de se connecter à Outlook sur le web ou le CAE

Problème

Lorsque vous essayez de vous connecter à Outlook sur le web ou le CAE dans Exchange Server, le navigateur web cesse de répondre ou vous voyez un message indiquant que la limite de redirection a été atteinte. En outre, l’événement 1003 est enregistré dans l’observateur d’événements.

ID d’événement : 1003 Source : proxy HTTPS frontal MSExchange Une erreur de serveur interne s’est produite. L’exception non gérée était : System.NullReferenceException : Référence d’objet non définie sur une instance d’un objet. à Microsoft.Exchange.HttpProxy.FbaModule.ParseCadataCookies(HttpApplication httpApplication)

La cause

Ce problème se produit car le certificat OAuth (Exchange Server Open Authentication) a expiré.

Résolution

Suivez les étapes décrites dans Impossible de se connecter à Outlook sur le web ou EAC.

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Impossible d’accéder à EAC ou Outlook sur le web après l’installation d’Exchange Server

Problème

Lorsque vous installez Exchange Server, le processus d’installation peut échouer ou être interrompu à une certaine étape, puis reprendre et enfin terminer correctement. Toutefois, lorsque vous essayez d’accéder à EAC ou Outlook sur le web après l’installation, vous recevez le message d’erreur suivant :

un problème s’est produit
Désolé, nous ne pouvons pas obtenir ces informations pour l’instant. Réessayez plus tard. Si le problème persiste, contactez votre support technique.

La cause

Ce problème se produit si le fichier SharedWebConfig.config est manquant à partir de l’un des emplacements suivants :

  • C :\Program Files\Microsoft\Exchange Server\V15\ClientAccess
  • C :\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy

Résolution

Suivez ces étapes :

  1. Sur le serveur sur lequel l’erreur se produit, identifiez l’emplacement à partir duquel le fichier SharedWebConfig.config est manquant.

  2. Générez le fichier manquant :

    1. Exécutez cd %ExchangeInstallPath%\bin pour modifier le répertoire actif vers le dossier bin qui se trouve sous le chemin d’installation d’Exchange.

    2. Utilisez l’outil DependentAssemblyGenerator pour générer le fichier selon les besoins :

      • Si le fichier est manquant dans C :\Program Files\Microsoft\Exchange Server\V15\ClientAccess, exécutez la commande suivante à l’invite de commandes :

        DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\ClientAccess" -configFile "%ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"
        
      • Si le fichier est manquant dans C :\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy, exécutez la commande suivante à l’invite de commandes :

        DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\FrontEnd\HttpProxy" -configFile "%ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"
        
  3. Exécutez la commande suivante dans une session PowerShell avec élévation de privilèges pour redémarrer le serveur :

    Restart-Service WAS,W3SVC
    

Pour plus d’informations, consultez l’ID d’événement 1309 et vous ne pouvez pas accéder à Outlook sur le web et ecP.

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Le programme d’installation d’Exchange Server ne s’exécute pas

Problème

Vous exécutez une installation sans assistance pour mettre à niveau Exchange Server depuis PowerShell ou sur l’invite de commandes à l’aide de Setup.exe. Le programme d’installation s’exécute, puis indique qu’il a terminé correctement. Toutefois, Exchange Server n’est pas mis à jour.

La cause

Vous avez démarré l’installation sans assistance en exécutant la commande suivante dans PowerShell ou à l’invite de commandes : setup.exe /m:upgrade /IAcceptExchangeServerLicenseTerms_DiagnosticDataON Toutefois, quel que soit le lecteur sur lequel se trouve le support d’installation, le système exécute le fichier Setup.exe situé dans le dossier C :\Program Files\Microsoft\Exchange Server\V15\bin .

Lorsque vous exécutez une commande dans PowerShell ou à l’invite de commandes, un chemin correspondant dans la variable d’environnement système est prioritaire sur le chemin actuel, sauf si l’une des conditions suivantes est remplie :

  • PowerShell : Vous entrez un point (.) devant la commande.
  • PowerShell : vous utilisez la touche Tab pour ajouter automatiquement une période devant la commande.
  • Vous spécifiez le chemin absolu du programme que vous souhaitez exécuter, par exemple D:\setup.exe.

Résolution

Mettez à niveau Microsoft Exchange Server à l’aide de l’une des commandes suivantes :

  • PowerShell : .\setup.exe /m:upgrade /IAcceptExchangeServerLicenseTerms_DiagnosticDataON
  • PowerShell ou invite de commandes : D:\setup.exe /m:upgrade /IAcceptExchangeServerLicenseTerms_DiagnosticDataON

Pour plus d’informations, consultez la configuration d’Exchange Server 2019 ne s’exécute pas comme prévu.

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Impossible d’installer le correctif de mise à niveau

Problème

Le message d’erreur suivant peut s’afficher lors de l’installation d’une unité de commande :

Le correctif de mise à niveau ne peut pas être installé par le service Windows Installer, car le programme à mettre à niveau peut être manquant ou le correctif de mise à niveau peut mettre à jour une autre version du programme. Vérifiez que le programme que vous voulez mettre à niveau se trouve sur votre ordinateur et que vous disposez du correctif de mise à jour correct.

La cause

Ce message d'erreur s'affiche si les versions de la mise à jour cumulative (CU) et de la mise à jour de sécurité (SU) ne correspondent pas.

Résolution

Soit mettez à jour vers le CU correct, soit téléchargez le SU correct pour le CU prévu.

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L’installation échoue, car les services ne s’arrêtent pas

Problème

L’installation échoue, car les services ne s’arrêtent pas correctement.

Résolution

Suivez la meilleure pratique pour redémarrer le serveur avant d’installer la mise à jour CU ou SU. Pour tous les logiciels antivirus que vous exécutez, définissez des exclusions appropriées ou désactivez le programme pendant l’installation. Si les services ne s’arrêtent pas ou ne démarrent pas comme prévu, procédez comme suit :

  1. Renommez le dossier C :\ExchangeSetupLogs . Par exemple, remplacez le nom ExchangeSetupLogs-OLDpar .

  2. Démarrez tous les services Exchange qui ont été arrêtés pendant l’installation et définissez-les pour démarrer automatiquement.

  3. Réexécutez la configuration.

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Les services ne démarrent pas après l’installation de la mise à jour logicielle (SU).

Problème

Les services Microsoft Exchange ne démarrent pas une fois que vous avez terminé l’installation de l’unité de commande.

Résolution

Démarrez tous les services Exchange qui ont été arrêtés pendant l’installation et définissez-les pour démarrer automatiquement.

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Erreur dans le journal d’installation d’Exchange lors de l’installation

Problème

Vous recevez le message d’erreur suivant dans le journal d’installation Exchange pendant l’installation :

Le programme d'installation a rencontré un problème lors de la validation de l'état d'Active Directory ou le rôle serveur de boîtes aux lettres n'est pas installé sur cet ordinateur.

Résolution 1

Téléchargez le script réviseur du journal d’installation Exchange ,SetupLogReviewer.ps1.

Exécutez la commande PowerShell suivante pour exécuter le script :

.\SetupLogReviewer.ps1 -SetupLog C:\ExchangeSetupLogs\ExchangeSetup.log

Le script vérifie le fichier ExchangeSetup.log et fournit des conseils sur la façon de résoudre le problème.

Résolution 2

Recherchez l’entrée d’erreur suivante dans le journal d’installation Exchange situé dans le dossier C :\ExchangeSetupLogs :

Le programme d’installation a rencontré un problème lors de la validation de l’état d’Active Directory : les objets au niveau de l’organisation Exchange n’ont pas été créés et le programme d’installation ne peut pas les créer, car l’ordinateur local ne se trouve pas dans le même domaine et le même site que le maître de schéma. Exécutez la configuration avec le /PrepareAD paramètre sur un ordinateur du domaine <domain_name> et du site <Default_First_Site_Name>, puis attendez que la réplication soit terminée.

Si vous trouvez cette entrée d’erreur, exécutez la commande suivante à partir d’un ordinateur qui se trouve dans le même domaine que le maître de schéma :

.\setup.exe /PrepareAD /IAcceptExchangeServerLicenseTerms_DiagnosticDataON

L’utilisateur qui exécute la commande doit être membre des groupes d’administration d’entreprise, d’administrateur de domaine et d’administration de schéma.

Remarque : Pour rechercher le contrôleur de domaine (DC) qui contient le maître de schéma, exécutez la commande suivante à l’aide d’une invite de commandes avec élévation de privilèges sur le contrôleur de domaine :

netdom query fsmo

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Erreur lors de l’installation de l’ensemble de mises à jour

Problème

Lorsque vous installez le correctif cumulatif sur un ordinateur qui n’est pas connecté à Internet, vous risquez de rencontrer un long délai d’installation. En outre, vous pouvez recevoir le message d’erreur suivant :

Création d’images natives pour les assemblys .NET.

La cause

Ce problème est dû aux demandes réseau pour se connecter à l’URL suivante :

http://crl.microsoft.com/pki/crl/products/CodeSigPCA.crl

Les demandes réseau tentent d’accéder à la liste de révocation de certificats pour chaque assembly pour lequel la génération d’images natives (Ngen) est compilée en code natif. Étant donné que le serveur exécutant Exchange Server n’est pas connecté à Internet, chaque requête doit expirer avant que le processus puisse continuer.

Résolution

Suivez ces étapes :

  1. Dans Internet Explorer, sélectionnez Outils>Options Internet.

  2. Sélectionnez l’onglet Avancé.

  3. Dans la section Sécurité , décochez la case Vérifier la révocation de certificats de l’éditeur , puis sélectionnez OK.

    Remarque

    Désactivez cette option de sécurité uniquement si l’ordinateur se trouve dans un environnement étroitement contrôlé.

  4. Une fois le processus d’installation terminé, cochez à nouveau la case Vérifier la révocation de certificats de l’éditeur .

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Le programme d’installation échoue avec l’erreur « Impossible de démarrer le service »

Problème

Le programme de configuration de CU échoue et génère le message d’erreur suivant :

Impossible de démarrer le service Hôte de service Microsoft Exchange

La cause

L'hôte de service Microsoft Exchange, ainsi que d'éventuels autres services Exchange, est arrêté et en mode Disabled.

Résolution

Suivez ces étapes :

  1. Renommez le dossier C :\ExchangeSetupLogs . Par exemple, remplacez le nom ExchangeSetupLogs-OLDpar .

  2. Démarrez tous les services Exchange qui ont été arrêtés pendant l’installation et définissez-les pour démarrer automatiquement.

  3. Exécutez la commande suivante à l'invite de commandes en mode administrateur pour reprendre l'installation :

    D:\setup.exe /m:upgrade /IAcceptExchangeServerLicenseTerms_DiagnosticDataON
    

    Cette commande suppose que le support de mise à jour cumulative Exchange se trouve sur le lecteur D :.

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Échec de l’installation de la mise à jour système en raison d’une mise à jour intermédiaire existante

Problème

Pendant l’installation du SU, le message d’erreur suivant peut s’afficher :

L’installation ne peut pas continuer. L’Assistant Installation a déterminé que cette mise à jour intermédiaire n’est pas compatible avec la configuration actuelle de Microsoft Exchange Server 2019 Cumulative Update 14.

Résolution 1

Étant donné que les mises à jour sont cumulatives, désinstallez la mise à jour intermédiaire précédemment installée (MI) avant d’appliquer cette mise à jour de sécurité. Vous trouverez les unités d’identité précédentes dans Ajouter/supprimer des programmes.

Résolution 2

Ce message d’erreur peut également apparaître sur un serveur qui n’a pas d’unités d’utilisateur installées, mais qui n’est pas connecté à Internet. Par conséquent, le serveur ne peut pas vérifier la liste de révocation de certificats. Dans ce cas, procédez comme suit :

  1. Dans Internet Explorer, sélectionnez Outils>Options Internet.

  2. Sélectionnez l’onglet Avancé.

  3. Dans la section Sécurité , décochez la case Vérifier la révocation de certificats de l’éditeur , puis sélectionnez OK.

    Remarque

    Désactivez cette option de sécurité uniquement si l’ordinateur se trouve dans un environnement étroitement contrôlé.

  4. Une fois le processus d’installation terminé, cochez la case Vérifier la révocation de certificats de l’éditeur .

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Le programme d’installation installe une ancienne mise à jour cumulative ou n’installe pas le pack de langue.

Problème

Lorsque vous essayez de procéder à la mise à niveau vers la dernière mise à jour cumulative, vous rencontrez l’un des problèmes suivants :

  • Le programme d’installation installe une ancienne mise à jour CU sur le serveur.

  • Le programme d’installation échoue et le message d’erreur suivant s’affiche :

    Impossible d’ouvrir le package « C :\Program Files\Microsoft\Exchange Server\V15\bin\Setup\<package name> ». Impossible d’ouvrir ce package d’installation. Vérifiez que le package existe et que vous pouvez y accéder, ou contactez le fournisseur de l’application pour vérifier qu’il s’agit d’un package Windows Installer valide. Le code d’erreur est 1619.

La cause

Ces problèmes se produisent si vous démarrez l’installation à partir de Windows PowerShell et utilisez une commande qui démarre dans setup.exe. Par exemple : setup.exe /m:upgrade /IAcceptExchangeServerLicenseTerms_DiagnosticDataON.

Résolution

Mettez à niveau Microsoft Exchange Server à l’aide d’une commande qui commence par .\setup.exe ou <drive letter>:\setup.exe, par exemple, l’une des commandes suivantes :

  • PowerShell : .\setup.exe /m:upgrade /IAcceptExchangeServerLicenseTerms_DiagnosticDataON

  • PowerShell ou invite de commandes : D:\setup.exe /m:upgrade /IAcceptExchangeServerLicenseTerms_DiagnosticDataON

    La commande suppose que le support de la mise à jour cumulative Exchange se situe sur le lecteur D :.

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Le redémarrage à partir de l’installation précédente est en attente

Problème

Vous recevez à plusieurs reprises le message d’erreur suivant, même après avoir redémarré le serveur plusieurs fois :

La configuration de Microsoft Exchange Server ne peut pas continuer, car un redémarrage à partir d’une installation ou d’une mise à jour précédente est en attente.

Résolution

Pour résoudre le problème, suivez les étapes de Redémarrage à partir d’une installation précédente en attente.

Si le message d’erreur persiste, procédez comme suit :

  1. Exécutez le script HealthChecker.

  2. Exécutez le script SetupAssist.ps1 .

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Le flux de messagerie s’est arrêté

Problème

Le flux de messagerie s’arrête après l’installation d’une mise à jour cumulative ou d’une mise à jour de sécurité.

Résolution

Pour que le flux de messagerie fonctionne à nouveau, vérifiez que les conditions suivantes sont remplies :

  1. Démarrez tous les services Exchange qui ont été arrêtés pendant l’installation et définissez-les pour démarrer automatiquement.

  2. Le serveur n’est pas en mode maintenance

  3. Il y a suffisamment d’espace libre disponible dans la base de données de file d’attente de messages Exchange.

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Erreur de configuration d'Exchange ou de PrepareAD

Problème

Lorsque vous exécutez l’installation d’Exchange ou la PrepareAD commande, le processus échoue et génère le message d’erreur suivant :

L’entrée d’objet connue B:<guid>:CN=Recipient Management\0ADEL:<guid>,CN=Deleted Objects,DC=contoso,DC=com sur l’attribut otherWellKnownObjects dans l’objet conteneur CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=contoso,DC=com pointe vers un DN non valide ou un objet supprimé. Supprimez l’entrée, puis réexécutez la tâche. dans Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)

Cause

Ce problème se produit parce que celui well-known object référencé dans le message d’erreur n’existe plus dans Active Directory.

Résolution

Procédez comme suit pour supprimer l’entrée d’objet non valide :

  1. Téléchargez le script SetupAssist.ps1 .

  2. Utilisez la commande suivante pour exécuter le script :

    .\SetupAssist.ps1 -OtherWellKnownObjects
    

    Le script écrit les entrées d’objet de l’attribut otherWellKnownObjects dans un fichier nommé ExchangeContainerOriginal.txt, puis vérifie les objets supprimés. Si des objets supprimés sont trouvés, le script génère un nouveau fichier nommé ExchangeContainerImport.txt, puis l’utilise pour supprimer les entrées non valides.

Si le script vous invite à vérifier les résultats, procédez comme suit :

  1. Passez en revue le fichier ExchangeContainerImport.txt pour voir les modifications apportées par le script.

  2. Importez le fichier ExchangeContainerImport.txt dans Active Directory en suivant les instructions fournies par le script.

  3. Réexécutez la PrepareAD commande, puis poursuivez l’installation.

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L’installation d’Exchange échoue et retourne le code d’erreur 1603

Problème

Lorsque vous essayez d’installer une mise à jour logicielle, vous recevez le message d’erreur suivant :

Échec de l’installation du produit F:\exchangeserver.msi. Erreur irrécupérable lors de l’installation. Le code d’erreur est 1603. La dernière erreur signalée par le package MSI est « Le programme d’installation dispose de privilèges insuffisants pour accéder à ce répertoire : C :\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\owa\auth\15.1.2106 ».

Résolution

Suivez ces étapes :

  1. Démarrez tous les services Exchange qui ont été arrêtés pendant l’installation et définissez-les pour démarrer automatiquement.

  2. Réessayez d’installer le SU.

Si le message d’erreur persiste, procédez comme suit :

  1. Veillez à utiliser un compte d’administrateur local pour exécuter l’installation.

  2. Vérifiez que les autorisations suivantes sont affectées au dossier spécifié dans le message d’erreur :

    • Autorisations de lecture pour les utilisateurs authentifiés
    • Autorisation contrôle total sur SYSTEM
    • Autorisation Contrôle total sur l’ordinateur<> local\Administrateurs
  3. Vérifiez que l’héritage est activé sur le dossier spécifié dans l’erreur.

  4. Réessayez d’installer le SU.

Si le message d’erreur se produit toujours, suivez les étapes de l’erreur 1603 lorsque vous essayez d’installer un package Windows Installer.

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Mettre à jour .NET lors de la migration à partir d’une cu non prise en charge

Si vous mettez à niveau Exchange Server d'un CU non pris en charge vers le CU actuel et qu'aucun CU intermédiaire n'est disponible, commencez par effectuer une mise à niveau vers la dernière version de .NET Framework prise en charge par votre version d'Exchange Server, puis procédez immédiatement à la mise à niveau vers le CU actuel. Cette méthode ne remplace pas l’exigence de maintenir vos serveurs Exchange à jour et sur la dernière mise à jour de l’uc prise en charge. Microsoft ne prétend pas qu’une défaillance de mise à niveau ne se produit pas à l’aide de cette méthode.

Important

Les versions de .NET Framework qui ne sont pas répertoriées dans les tables de la matrice de prise en charge Exchange Server ne sont pas prises en charge sur une version d’Exchange Server. Cela inclut des versions mineures et de mise à jour de .NET Framework.

Pour installer la dernière version de .NET Framework, procédez comme suit :

  1. Exécutez la commande suivante pour placer le serveur en mode maintenance :

    Set-ServerComponentState <server name> -Component ServerWideOffline -State Inactive -Requester Maintenance
    
  2. Arrêtez tous les services Exchange à l’aide du composant logiciel enfichable Services ou de PowerShell. Pour utiliser PowerShell, exécutez la commande suivante deux fois pour arrêter tous les services Exchange :

    Get-Service -DisplayName "Microsoft Exchange*" | Stop-Service
    

    Remarque : nous vous recommandons de ne pas utiliser la -Force commande pour arrêter tous les services.

  3. Téléchargez et installez la version correcte de .NET Framework en fonction de la matrice de prise en charge d’Exchange Server.

  4. Une fois l’installation terminée, redémarrez le serveur.

  5. Mettez à jour vers la dernière mise à jour cumulative disponible pour Exchange Server.

  6. Après l'installation de la mise à jour cumulative, redémarrez le serveur.

  7. Démarrez tous les services Exchange qui ont été arrêtés pendant l’installation et définissez-les pour démarrer automatiquement.

  8. Exécutez la commande suivante pour retirer le serveur du mode maintenance :

    Set-ServerComponentState <server name> -Component ServerWideOffline -State Active -Requester Maintenance
    

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Gérer des fichiers Outlook personnalisés sur le web ou .config

Important

Avant d’appliquer un CU, effectuez une copie de sauvegarde de vos fichiers personnalisés.

Lorsque vous appliquez une CU pour Exchange Server, le processus met à jour les fichiers d'Outlook sur le web et les fichiers .config. Par conséquent, toutes les personnalisations que vous apportez aux paramètres Exchange ou Internet Information Server (IIS) dans les fichiers de configuration d’application XML Exchange sur le serveur Exchange seront remplacées lorsque vous installez une cu Exchange. Par exemple, ces fichiers de configuration d’application incluent des fichiersWeb.config , des fichiersEdgeTransport.exe.config et tous fichiers Logon.aspx personnalisés pour Outlook sur le web. Veillez à enregistrer ces informations pour pouvoir facilement réappliquer les paramètres après l’installation de la cu.

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Installer la mise à jour pour le déploiement de proxys CAS-CAS

Si votre scénario remplit les deux conditions suivantes, appliquez le correctif cumulatif sur le serveur d’accès client accessible sur Internet avant d’appliquer le correctif cumulatif sur le site d’administration centrale non accessible sur Internet :

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Plus d’informations

Démarrer les services Microsoft Exchange

Procédez comme suit pour vérifier l’état des services Microsoft Exchange et, si nécessaire, les démarrer et les configurer pour démarrer automatiquement au démarrage :

  1. Redémarrez le serveur Exchange sur lequel l’installation a échoué.

  2. Exécutez la commande PowerShell suivante pour vérifier l’état des services Exchange :

    Get-Service -DisplayName "Microsoft Exchange*" | FT DisplayName, StartType, Status
    

    Remarque

    Par défaut, les services POP3 et IMAP4 (MSExchangeIMAP4, MSExchangeIMAP4BE, MSExchangePOP3 et MSExchangePOP3BE) sont arrêtés et ne sont pas définis pour démarrer automatiquement. Ne configurez pas les services POP3 et IMAP4 pour qu’ils s’exécutent, sauf si les utilisateurs en ont besoin. Vérifiez le journal Exchange situé dans C :\ExchangeSetupLogs\ServiceControl.log pour voir quels services Exchange ont été désactivés lors d’une installation de cu ou de su. Restaurez uniquement les services Exchange actifs avant la tentative d’installation.

  3. Si la valeur du paramètre StartType pour un service Exchange est Disabled, exécutez les commandes suivantes dans PowerShell pour restaurer la valeur sur Automatic:

    cd "C:\Program Files\Microsoft\Exchange Server\V15\Bin"
    ​​​​​​Add-PSSnapin -Name Microsoft.Exchange.Management.PowerShell.Setup -ErrorAction SilentlyContinue
    .\ServiceControl.ps1 AfterPatch
    

    Vous pouvez confirmer que la valeur du paramètre StartType est Automatic en exécutant la commande PowerShell suivante :

    Get-Service -DisplayName "Microsoft Exchange*" | FT DisplayName, StartType, Status
    
  4. Exécutez la commande PowerShell suivante pour démarrer manuellement tous les services Exchange :

    Get-Service -DisplayName "Microsoft Exchange*" | Start-Service
    

    Ou exécutez la commande suivante pour démarrer manuellement tous les services, à l’exception des services POP3 et IMAP4 :

    Get-Service -DisplayName "Microsoft Exchange*" | Where-Object { $_.DisplayName -notlike "*POP3*" -and $_.DisplayName -notlike "*IMAP4*" } | Start-Service