Erreur lors du téléchargement de ConfigMgr.AdminUIContent.cab à l’aide de SMS_DMP_DOWNLOADER ou de ServiceConnectionTool.exe

Lorsque vous utilisez le mode en ligne du point de connexion de service ou l’outil de connexion de service pour télécharger les mises à jour dans Configuration Manager, vous recevez un message d’erreur AdminUIContentDownload.

Version du produit d’origine : Configuration Manager (Current Branch)
Numéro de la base de connaissances d’origine : 4561945

Symptômes

  • Si le point de connexion de service (SMS_DMP_DOWNLOADER) est défini sur le mode en ligne, vous remarquerez peut-être qu’aucune nouvelle version de Configuration Manager n’apparaît dans la console. En outre, l’entrée d’erreur suivante est enregistrée dans le fichier DmpDownloader.log :

    Redirigé vers l’URL https://configmgrbits.azureedge.net/adminuicontent/ConfigMgr.AdminUIContent.cab~~
    Fwdlink et recréation de httprequest/response~~
    ERREUR : Échec du téléchargement de Administration charge utile du contenu de l’interface utilisateur avec l’exception : La connexion sous-jacente a été fermée : une erreur inattendue s’est produite lors d’un envoi.~~
    Échec de l’appel de AdminUIContentDownload. error = Error -2146233079~

  • Le point de connexion de service est défini sur le mode hors connexion. Vous utilisez l’outil de connexion de service (ServiceConnectionTool.exe) pour télécharger et importer des mises à jour dans Configuration Manager. En outre, l’entrée d’erreur suivante est enregistrée dans le fichier ServiceConnectionTool.log :

    ERROR:AdminUIContentDownload:DownloadManifestCab exception : la connexion sous-jacente a été fermée : une erreur inattendue s’est produite lors d’un envoi. Il peut y avoir un problème avec la connexion Internet ou le lien de téléchargement.

Cause

Ce problème se produit dans l’une des situations suivantes :

  • TLS 1.2 n’est pas activé pour .NET Framework sur l’ordinateur qui exécute le point de connexion de service en ligne ou l’outil de connexion de service. TLS 1.2 est requis pour télécharger le fichier .cab.
  • Les URL spécifiques requises par le point de connexion de service ne sont pas incluses dans la liste d’autorisation de votre pare-feu ou serveur proxy.

Résolution

Remarque

  • Si vous ne l’avez pas déjà fait, envisagez de mettre à niveau le serveur qui héberge le point de connexion de service vers Windows Server 2016 ou versions ultérieures.
  • Vérifiez que toutes les règles et exceptions Internet sont configurées pour votre proxy ou pare-feu afin d’autoriser le point de connexion de service à accéder aux points de terminaison Internet. Pour plus d’informations, consultez Conditions requises pour l’accès à Internet et Configuration Manager exceptions de proxy.
  • Vérifiez que les suites de chiffrement suivantes sont activées sur le serveur qui héberge le point de connexion de service :
    • TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (0xc030)
    • TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 (0xc02f)
    • TLS_DHE_RSA_WITH_AES_256_GCM_SHA384 (0x9f)
    • TLS_DHE_RSA_WITH_AES_128_GCM_SHA256 (0x9e)

Sur l’ordinateur qui exécute le point de connexion de service en ligne ou l’outil de connexion de service, activez TLS 1.2. En particulier, si des mises à jour .NET Framework sont installées, définissez les valeurs de Registre suivantes, puis redémarrez l’ordinateur :

Sous-clé : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319

Valeurs :

  • SystemDefaultTlsVersions = DWORD:00000001
  • SchUseStrongCrypto = DWORD:00000001

Pour plus d’informations sur les URL spécifiques requises par le point de connexion de service, consultez Point de connexion de service.

Solution de contournement

  1. À partir de l’erreur dans le fichier DMPDownloader.log, copiez l’URL et téléchargez manuellement le fichier .cab.
  2. Copiez le fichier .cab dans le <dossier ConfigMgr Install Dir>\Inboxes\HMAN.box\CFD.
  3. Surveillez le fichier HMAN.log pour les détails du traitement.