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Erreur AADSTS50011 lorsque vous interrogez Intune Data Warehouse

Cet article vous aide à résoudre un problème dans lequel vous recevez une erreur « L’URL de réponse spécifiée dans la demande ne correspond pas aux URL de réponse configurées pour l’application » lorsque vous interrogez Intune Data Warehouse.

Symptôme

Lorsque vous interrogez Intune Data Warehouse à l’aide de PowerShell ou d’une application personnalisée, vous recevez un message d’erreur qui contient les éléments suivants :

AADSTS50011 : l’URL de réponse spécifiée dans la demande ne correspond pas aux URL de réponse configurées pour l’application : «< ID d’application affecté par Azure AD> ».

Cause

Ce problème se produit si l’URI de redirection par défaut pour l’inscription de l’application ou PowerShell est supprimé.

Solution

Pour résoudre ce problème, procédez comme suit :

  • Si vous utilisez PowerShell, vérifiez que l’URI de redirection par défaut est défini.

    Voici un exemple :

    PowerShell
    $redirectUri = "urn:ietf:wg:oauth:2.0:oob"
    
  • Si vous utilisez une application personnalisée, procédez comme suit :

    1. Connectez-vous au Portail Azure.

    2. Sélectionnez Inscriptions d’application d’ID>Microsoft Entra.

    3. Dans la zone de recherche, entrez l’ID d’application dans le message d’erreur pour trouver l’application.

    4. Sélectionnez l’application, puis sélectionnez Authentification sous Gérer.

    5. Sous URI de redirection, ajoutez l’URI suivant :

      Type : client public (mobile &bureau)
      URI de redirection : urn :ietf :wg :oauth :2.0 :oob

      Capture d’écran du type et de la valeur de l’URI de redirection.

Plus d’informations

Pour plus d’informations sur les URI de redirection et l’inscription d’application, consultez Ajouter des URI de redirection à votre application.