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Erreur « Exception interdite retournée par le serveur Http » lors du test d’une boîte aux lettres Dynamics 365

Cet article fournit une solution à une erreur qui se produit lorsque vous sélectionnez le bouton Tester et activer la boîte aux lettres sur un enregistrement de boîte aux lettres dans Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de base de connaissances d’origine : 4483440

Symptômes

Lorsque vous sélectionnez le bouton Tester et activer la boîte aux lettres sur un enregistrement de boîte aux lettres dans Dynamics 365, la section résultats des tests affiche l’échec et l’alerte suivante est enregistrée :

Le message électronique « Votre boîte aux lettres est maintenant connectée à Dynamics 365 » ne peut pas être envoyé, car une erreur s’est produite lors de l’établissement d’une connexion sécurisée au serveur de messagerie. La boîte aux lettres [Nom de la boîte aux lettres] n’a pas été synchronisée. Le propriétaire du profil de serveur de messagerie Microsoft Exchange Online a été averti.
Code d’erreur du serveur de messagerie : le serveur Http a retourné l’exception Interdit.

Si vous sélectionnez Détails, les détails suivants sont affichés :

Erreur : System.Net.WebException : La requête a échoué avec l’état HTTP 403 : Interdit.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
sur System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
sur Microsoft.Crm.Asynchrone.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
sur Microsoft.Crm.Asynchrone.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

Cause

Dynamics 365 communique avec Microsoft Exchange à l’aide de requêtes EWS (Exchange Web Services). Si EWS est désactivé, cette erreur se produit. Voici quelques façons potentielles de désactiver ou de restreindre EWS dans Exchange :

  1. EWS est désactivé pour la boîte aux lettres.
  2. EWS est désactivé pour l’ensemble de l’organisation.
  3. L’option EwsApplicationAccessPolicy est définie sur EnforceAllowList et elle EwsAllowList n’autorise pas l’accès à partir de Dynamics 365.
  4. Est EwsApplicationAccessPolicy défini sur EnforceBlockList et EwsBlockList inclut Dynamics 365.

Résolution

Vérifiez si EWS est désactivé pour la boîte aux lettres si le problème se produit uniquement pour certaines boîtes aux lettres

  1. Tout d’abord, vérifiez si EWS est désactivé pour une boîte aux lettres spécifique à l’aide de cette commande PowerShell :

    Get-CASMailbox <mailbox-alias> | ft EwsEnabled
    
  2. Si EwsEnabled a la valeur False, activez-le à l’aide de cette commande :

    Set-CASMailbox <mailbox-alias> -EwsEnabled $True
    

    Important

    Après avoir exécuté cette commande, la modification du paramètre peut prendre jusqu’à 120 minutes.

Vérifiez si EWS est désactivé au niveau de l’organisation ou si EwsAllowList limite le trafic EWS

  1. Utilisez cette commande PowerShell pour vérifier les paramètres au niveau de l’organisation :

    Get-OrganizationConfig |ft Name, EwsEnabled,EwsApplicationAccessPolicy,EwsBlockList,EwsAllowList
    
  2. Vérifiez qu’il EwsEnabled n’est pas défini sur False. Si c’est le cas, activez-le à l’aide de :

    Set-OrganizationConfig -EwsEnabled $True
    

    Important

    Après avoir exécuté cette commande, la modification du paramètre peut prendre jusqu’à 120 minutes.

  3. Si EwsApplicationAccessPolicy elle est définie sur EnforceAllowList, vérifiez si la EwsAllowList valeur contient crm (par exemple, CRM/*) pour permettre à Dynamics 365 (CRM) de communiquer avec Exchange. Si ce n’est pas le cas, utilisez la commande suivante pour mettre à jour la liste pour inclure CRM/* et les autres applications que vous souhaitez autoriser. Dans cet exemple <, PreviousAllowedList> est la liste des applications qui se trouvaient précédemment dans la liste verte :

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceAllowList -EwsAllowList:CRM/*,<PreviousAllowedList>
    

    Important

    Après avoir exécuté cette commande, la modification du paramètre peut prendre jusqu’à 120 minutes.

  4. Si EwsApplicationAccessPolicy elle est définie sur EnforceBlockList, vérifiez si la EwsBlockList valeur contient crm (par exemple, CRM/*), ce qui empêche Dynamics 365 (CRM) de communiquer avec Exchange. Si c’est le cas, utilisez la commande suivante pour mettre à jour la liste pour ne plus inclure CRM. Dans cet exemple <, PreviousBlockList WITH CRM REMOVED> est la liste des applications qui se trouvaient précédemment dans la liste de blocs, à l’exception de CRM :

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceBlockList -EwsBlockList:<PreviousBlockList WITH CRM REMOVED>
    

    Important

    Après avoir exécuté cette commande, la modification du paramètre peut prendre jusqu’à 120 minutes.

Plus d’informations

Pour plus d’informations sur la modification des paramètres Exchange à l’aide de PowerShell et le contrôle de l’accès à EWS, consultez les articles suivants :