Diagnostiquer les échecs de réplication Active Directory

Cet article explique comment diagnostiquer les échecs de réplication Active Directory.

S’applique à : Windows Server 2008 R2 Service Pack 1
Numéro de la base de connaissances d’origine : 2498185

Symptômes

Vous remarquerez peut-être qu’Active Directory ne parvient pas à répliquer dans les conditions suivantes :

  • L’outil de surveillance Repadmin expose les échecs de réplication.
  • Les administrateurs, les utilisateurs ou les applications détectent que les objets créés et modifiés dans Active Directory n’existent pas sur tous les contrôleurs de domaine dans une étendue de réplication commune.

Cause

La réplication services de domaine Active Directory (AD DS) a les dépendances suivantes :

  • Connectivité réseau sur les ports et protocoles utilisés par le service ADDS
  • Résolution de noms DNS pour résoudre le nom d’un partenaire de réplication en son adresse IP
  • Authentification et autorisation
  • Précision du temps dans les 5 minutes pour prendre en charge l’authentification Kerberos
  • Base de données d’annuaires
  • Topologie de réplication Active Directory pour créer des objets de connexion entre les partenaires de réplication
  • Moteur de réplication ADDS

Résolution

Utilisez l’une des méthodes suivantes pour afficher les erreurs de réplication :

  • Téléchargez et exécutez l’outil Assistant Support Microsoft et récupération.

  • Lisez le status de réplication dans la repadmin /showrepl sortie.

    • Repadmin fait partie des outils d’administration de serveur distant (RSAT). Si vous utilisez Windows 10, version 1803 ou une version antérieure de Windows, téléchargez les Outils d’administration de serveur distant (RSAT).

    • Dans Windows 10, version 1809 et les versions ultérieures de Windows 10, vous pouvez installer la fonctionnalité RSAT via paramètres>Gérer les fonctionnalités facultatives.

Utiliser repadmin pour identifier les erreurs de réplication Active Directory à l’échelle de la forêt

Vous pouvez créer une feuille de calcul Microsoft Excel pour les contrôleurs de domaine à l’aide de la repadmin/showrepl commande pour afficher les erreurs de réplication. Pour ce faire, procédez comme suit :

  1. Ouvrez une invite de commandes en tant qu’administrateur :

    Dans le menu Démarrer, cliquez avec le bouton droit sur Invite de commandes, puis sélectionnez Exécuter en tant qu’administrateur. Si la boîte de dialogue Contrôle de compte d’utilisateur s’affiche, fournissez les informations d’identification des administrateurs d’entreprise, puis sélectionnez Continuer.

  2. À l’invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :

    repadmin /showrepl * /csv >showrepl.csv
    
  3. Dans Excel, ouvrez showrepl.csv.

  4. Mettez en forme la feuille de calcul comme suit :

    1. Masquer ou supprimer les colonnes A et G.
    2. Sélectionnez la ligne 1 sous la ligne d’en-tête de colonne. Sous l’onglet Affichage , sélectionnez Figer les volets>Figer la ligne supérieure.
    3. Sélectionnez la feuille de calcul entière. Sous l’onglet Données , sélectionnez Filtrer.
    4. Dans la colonne Dernière heure de réussite , sélectionnez la flèche vers le bas, pointez sur Filtres de texte, puis sélectionnez Filtre personnalisé.
    5. Triez la table de la plus ancienne à la plus récente.
    6. Dans la colonne Contrôleur de domaine source ou DSA source , sélectionnez la flèche de filtre vers le bas, pointez sur Filtres de texte, puis sélectionnez Filtre personnalisé.
    7. Dans la boîte de dialogue Filtre automatique personnalisé , sous Afficher les lignes où, sélectionnez ne contient pas. Dans la zone de texte adjacente, tapez del pour éliminer les contrôleurs de domaine supprimés de la vue.
    8. Répétez l’étape 6 pour la colonne Heure de la dernière défaillance , mais utilisez la valeur n’est pas égale, puis tapez la valeur 0.
  5. Pour corriger les échecs de réplication qui apparaissent sous État du dernier échec, consultez Comment résoudre les erreurs courantes de réplication Active Directory.

Collecte de données

Si vous avez besoin d’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes de réplication Active Directory.