"Operation has timed out" error when using New-MoveRequest to move a mailbox from Exchange Online to on-premises
Symptoms
You have a hybrid deployment of Microsoft Exchange Online in Microsoft 365 and of your on-premises Microsoft Exchange Server environment. When you try to use the New-MoveRequest Windows PowerShell cmdlet to move or offboard a mailbox from Microsoft 365 to the on-premises environment, the mailbox isn't moved. Additionally, you may receive an error message that resembles the following:
The call to '
https://webmail.domain.com/EWS/mrsproxy.svc
' timed out.
The operation has timed out
+ CategoryInfo : NotSpecified: (0:Int32) [New-MoveRequest], RemoteTransientException
+ FullyQualifiedErrorId : 725EBC5,Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest
Cause
This issue may occur if incorrect syntax is used for domain names and host names in the New-MoveRequest
cmdlet.
Resolution
To resolve this issue, make sure that you use the correct syntax for domain names and host names in the New-MoveRequest
cmdlet. The New-MoveRequest
cmdlet requires all domain names and host names to be enclosed in single quotation marks (').
The following is an example of incorrect syntax:
'alias' | New-MoveRequest -Outbound -RemoteHostName webmail.contoso.com -RemoteCredential $onprem -RemoteTargetDatabase Database1 -TargetDeliveryDomain contoso.com
The following is an example of correct syntax. (Note that this example uses single quotation marks around domain names and host names.)
'alias' | New-MoveRequest -OutBound -RemoteTargetDatabase 'Database1' -RemoteHostName 'webmail.contoso.com' -RemoteCredential $onprem -TargetDeliveryDomain 'contoso.com'
More information
For more information about how to use the New-MoveRequest
cmdlet, see Understanding Move Requests.
If you experience issues when you move mailboxes to Exchange Online in Microsoft 365, you can run the Troubleshoot migration issues in Exchange Server hybrid environment tool. This diagnostic is an automated troubleshooting tool. If you're experiencing a known issue, you receive a message that states what went wrong. The message includes a link to an article that contains the solution. Currently, the tool is supported only in Internet Explorer.
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