Errore "Impossibile trovare il database" quando si eseguono cmdlet per una cassetta postale ospitata in un'area Exchange Online diversa

Sintomi

Si supponga di essere un amministratore dell'account. Quando si tenta di New-MailboxSearcheseguire il cmdlet , Search-MailboxAuditLog, New-MailboxImportRequesto New-MailboxRestoreRequest per una cassetta postale ospitata in un'area diversa dall'area dell'account, viene visualizzato uno dei seguenti messaggi di errore:

Impossibile trovare il database "<database>". Assicurati di aver digitato correttamente.

Impossibile connettersi alla cassetta postale del guid <GUID> del database delle cassette postali dell'utente perché l'oggetto ExchangePrincipal contiene informazioni obsolete. La cassetta postale potrebbe essere stata spostata di recente.

Tuttavia, in questo scenario, è possibile eseguire le azioni seguenti:

  • È possibile eseguire correttamente questi cmdlet per una cassetta postale ospitata nella stessa area geografica dell'account.
  • È possibile eseguire correttamente altri cmdlet, ad Set-CalendarProcessing esempio o Get-Mailbox, per le cassette postali ospitate in un'area diversa.

Causa

Questi cmdlet hanno esito negativo per le cassette postali che si trovano in un'area diversa dall'area in cui si trova l'account amministratore. Un account amministratore può avere una cassetta postale in un'area specifica oppure un account utente abilitato alla posta elettronica che può connettersi alle cassette postali di arbitraggio nell'area predefinita.

Soluzione alternativa

Per risolvere questo problema, è possibile forzare una connessione a un'altra area ConnectionUri modificando il valore del parametro quando si utilizza il New-PSSession cmdlet. Ad esempio, è possibile eseguire il cmdlet seguente:

New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid?email=alias@contoso.com-Credential $UserCredential -Authentication Basic -AllowRedirection

L'indirizzo di posta elettronica ConnectionUri aggiunto nel parametro deve essere per una cassetta postale nell'area New-MailboxSearchper cui si desidera eseguire il cmdlet , Search-MailboxAuditLog, New-MailboxImportRequesto New-MailboxRestoreRequest .

Ad esempio, se la cassetta postale si trova nell'area dell'Unione Europea e si desidera eseguire il cmdlet su una cassetta postale nell'area di Stati Uniti, è necessario individuare una cassetta postale nell'area di Stati Uniti (può essere qualsiasi cassetta postale nell'areaConnectionUri) e quindi aggiungere l'indirizzo di posta elettronica di tale cassetta postale al parametro . Per eseguire questa operazione, non è necessario disporre di autorizzazioni speciali per la cassetta Stati Uniti cassetta postale. L'aggiunta dell'indirizzo di posta elettronica forza la connessione nell'Stati Uniti geografica. In questo modo i cmdlet possono essere eseguiti correttamente per una Stati Uniti cassetta postale.