Errore "Crystal Print Engine Error 723" durante la stampa o l'anteprima di un report personalizzato in Microsoft Dynamics SL

Questo articolo fornisce una soluzione alternativa per un problema in cui viene visualizzato il messaggio di errore Errore 723 del motore di stampa Crystal quando si tenta di stampare o stampare in anteprima un report personalizzato in Microsoft Dynamics SL.

Si applica a: Microsoft Dynamics SL 2011
Numero KB originale: 930445

Sintomi

Quando si tenta di stampare o visualizzare in anteprima un report personalizzato in Microsoft Dynamics SL, viene visualizzato un messaggio di errore simile al messaggio seguente:

Impossibile avviare il processo di stampa.
Report: C:\Programmi\Solomon\Usr_Rpts\CUSTOM. RPT
Errore del motore di stampa Crystal: 723 - Errore nel file
C:\Programmi\Solomon\Usr_Rpts\CUSTOM. RPT: impossibile aprire un set di righe.

Questo problema si verifica se si verificano le condizioni seguenti:

  • Il report personalizzato contiene un campo parametro.
  • Digitare il valore appropriato quando il report richiede un parametro.
  • Nella scheda Seleziona della schermata Interprete opzioni report (ROI) specificare criteri di selezione aggiuntivi.

Causa

Questo problema si verifica perché la schermata Dell'interprete opzioni report (ROI) concatena erroneamente le clausole WHERE presenti nei criteri di selezione e nel campo del parametro.

Soluzione alternativa

Per risolvere questo problema, non includere il campo del parametro nel report personalizzato. Creare invece i criteri di selezione dei parametri nella scheda Seleziona della schermata Interprete opzioni report ( ROI ).