Slow performance in Application Server in Microsoft Dynamics SL
This article provides a resolution for the slow performance issue that occurs in Application Server in Microsoft Dynamics SL.
Applies to: Microsoft Dynamics SL 2011, Microsoft Dynamics SL 2011 Service Pack 1
Original KB number: 2732983
Symptoms
You notice that Application Server (96.010.00) requires an extended length of time to process each request.
Cause
A large number of application server log records exist, which causes a delay when application server tries to read from the appsrvlog table.
Resolution
Limit the Application Server Log size. To do this, follow these steps:
- Open Microsoft Dynamics SL.
- Select the Foundation module.
- In the Application Server, select Server Administration.
- Select an application server and right-click and select properties.
- In the properties window, select the Management tab.
- Populate the settings under Log Management.
Recommended settings are 1000 - 2000 logs and 21 days.