Slow performance in Application Server in Microsoft Dynamics SL

This article provides a resolution for the slow performance issue that occurs in Application Server in Microsoft Dynamics SL.

Applies to:   Microsoft Dynamics SL 2011, Microsoft Dynamics SL 2011 Service Pack 1
Original KB number:   2732983

Symptoms

You notice that Application Server (96.010.00) requires an extended length of time to process each request.

Cause

A large number of application server log records exist, which causes a delay when application server tries to read from the appsrvlog table.

Resolution

Limit the Application Server Log size. To do this, follow these steps:

  1. Open Microsoft Dynamics SL.
  2. Select the Foundation module.
  3. In the Application Server, select Server Administration.
  4. Select an application server and right-click and select properties.
  5. In the properties window, select the Management tab.
  6. Populate the settings under Log Management.

Recommended settings are 1000 - 2000 logs and 21 days.