"Il percorso del server di posta elettronica o la porta di posta elettronica in ingresso specificata nel profilo del server di posta elettronica associato [nome profilo] non è corretto" si verifica in Microsoft Dynamics 365
Questo articolo fornisce una soluzione a un errore che si verifica quando si tenta di testare e abilitare una cassetta postale in Microsoft Dynamics 365.
Si applica a: Microsoft Dynamics 365
Numero KB originale: 4463808
Sintomi
Quando si tenta di testare e abilitare una cassetta postale in Microsoft Dynamics 365, viene visualizzato l'errore seguente:
"non è possibile ricevere Email per la cassetta postale [nome cassetta postale] perché il percorso del server di posta elettronica o la porta di posta elettronica in ingresso specificata nel profilo del server di posta elettronica associato [nome profilo] non è corretto. La cassetta postale non è stata sincronizzata. Al proprietario del profilo del server di posta elettronica è stata inviata una notifica.
Email Codice di errore del server: il socket ha restituito l'eccezione InvalidIncomingEmailServerProfileConfiguration HostNotFound."
Se si selezionano i dettagli, vengono visualizzati i dettagli aggiuntivi seguenti:
"ActivityId: <GUID>
>Errore: System.Net.Sockets.SocketException (0x80004005): nessun host di questo tipo è noto
in System.Net.Dns.GetAddrInfo(String name)
in System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
in System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
in System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
in Microsoft.Crm.Asynchronous.EmailConnector.Pop3Client.Connect()"
Causa
Questo errore può verificarsi se il percorso o la porta del server nel profilo del server di posta elettronica non è corretto.
Risoluzione
Passare a Impostazioni, Email Configurazione e quindi selezionare Email Profili server.
Aprire il profilo del server Email usato dalla cassetta postale che soddisfa questo errore.
Nota
È anche possibile selezionare il nome del Email Profilo server all'interno del messaggio di errore. Viene visualizzato come collegamento ipertestuale che aprirà il record del profilo del server Email corretto.
Verificare il valore Percorso server in ingresso .
Nota
Per gli indirizzi corretti, vedere la documentazione del provider di posta elettronica. Per Gmail, il percorso del server in ingresso sarà
pop.gmail.com
e il percorso del server in uscita saràsmtp.gmail.com
.Selezionare Avanzate.
Verificare il valore porta in ingresso e quindi selezionare Salva.
Nota
Fare riferimento alla documentazione del provider di posta elettronica per le porte corrette da usare per la connessione al servizio SMTP. Per Gmail, la porta POP3 in ingresso è 995 e la porta SMTP in uscita è 587.
Selezionare Cassette postali e quindi selezionare la cassetta postale che ha ricevuto l'errore.
Selezionare il pulsante Test & abilita cassette postali .
Al termine dei test, aprire il record della cassetta postale e visualizzare la sezione Avvisi se i risultati non vengono visualizzati come Esito positivo.
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