Errore del file già presente durante la configurazione di Microsoft Dynamics CRM per Microsoft Office Outlook

Questo articolo fornisce una soluzione a un errore che si verifica quando si configura Microsoft Dynamics CRM per Microsoft Office Outlook.

Si applica a: Microsoft Dynamics CRM Online, Microsoft Dynamics CRM 2016, Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013, client Microsoft CRM per Microsoft Office Outlook
Numero KB originale: 3183053

Sintomi

Quando si tenta di configurare Microsoft Dynamics CRM per Microsoft Office Outlook, viene visualizzato l'errore seguente:

"Si è verificato un problema durante la comunicazione con il server Microsoft Dynamics CRM. Il server potrebbe non essere disponibile. Riprovare più tardi. Se il problema persiste, contattare l'amministratore di sistema.

Il file esiste già. Provare a usare un nome di database diverso. [ Nome file = C:\Users\<USER>\AppData\Local\Microsoft\MSCRM\Client\MetadataCache-5243bc89-09f7-4d12-b578-8efd890f5d7c.sdf ]..."

Causa

Questo errore può verificarsi se esiste già un file di database di una configurazione precedente per l'istanza di CRM.

Risoluzione

Opzione 1 (CRM Online)

  1. Se si usa CRM Online, è possibile eseguire supporto tecnico Microsoft e Recovery Assistant, che possono risolvere questo problema.
  2. Scegliere l'opzione Dynamics CRM Online e quindi selezionare Problemi durante l'installazione, la connessione o l'abilitazione di CRM per Outlook (client Outlook).
  3. Continuare con la procedura guidata. L'azione Rimuovi file di cache usati da CRM per Outlook verrà visualizzata e rimuoverà il file esistente a cui si fa riferimento nell'errore.
  4. Eseguire di nuovo la Configurazione guidata Microsoft Dynamics CRM.

Opzione 2 (manuale)

Se non si usa CRM Online o si preferisce risolvere il problema manualmente, seguire questa procedura.

  1. Chiudere Outlook.

  2. Aprire Esplora risorse e passare a <install directory>:\Users\<Your User>\AppData\Local\Microsoft\MSCRM\Client.

    Esempio: C:\Users\<username>\AppData\Local\Microsoft\MSCRM\Client

    Nota

    La cartella AppData è nascosta per impostazione predefinita. È possibile modificare le impostazioni di visualizzazione per visualizzare elementi nascosti oppure copiare e incollare il percorso seguente nel percorso della cartella:
    %localappdata%\Microsoft\MSCRM\Client

  3. Eliminare il file a cui si fa riferimento nei dettagli dell'errore.

  4. Eseguire di nuovo la Configurazione guidata Microsoft Dynamics CRM.