Non è possibile connettersi all'errore del server Microsoft Dynamics 365 quando si usa Microsoft Dynamics 365 App per Outlook

In questo articolo viene fornita una soluzione per il problema che non è possibile utilizzare l'app Microsoft Dynamics 365 per Outlook a causa dell'errore del server Microsoft Dynamics 365.

Si applica a:   Microsoft Dynamics 365
Numero KB originale:   4341413

Sintomi

Quando si tenta di usare l'app Microsoft Dynamics 365 per Outlook, viene visualizzato il messaggio seguente:

"Non è possibile connettersi al server Microsoft Dynamics 365. Prova a chiudere e riaprire l'app."

Se si seleziona Mostra altro, potrebbe essere visualizzato il messaggio seguente:

"Timeout del caricatore client"

Se usi l'app in Outlook Web Access (OWA), nella parte inferiore dello schermo potrebbe essere visualizzato il seguente prompt:

"Vuoi consentire dynamics.com l'uso di spazio di archiviazione aggiuntivo nel computer?"

Se si cancella la cache del browser Internet Explorer, è possibile che l'errore venga risolto ma alla fine venga restituito.

Causa

Microsoft è a conoscenza di un problema a causa del quale questo errore può verificarsi perché Internet Explorer è configurato per limitare la quantità di dati che possono essere memorizzati nella cache. Se stai visualizzando l'app con Internet Explorer, questa potrebbe essere la causa dell'errore. Se si verifica questo errore usando Outlook Desktop, Outlook internet explorer viene sempre utilizzato per visualizzare l'app.

Risoluzione

Microsoft sta lavorando a una modifica per evitare questo problema. Nel frattempo, è possibile utilizzare la procedura seguente come potenziale soluzione alternativa:

Opzione 1 - Aumentare il limite di database nelle opzioni di Internet Explorer

A seconda della versione del sistema operativo, potresti essere in grado di modificare il limite nelle impostazioni di Internet Explorer. Se si utilizza Windows 10, questa opzione non viene visualizzata ed è possibile utilizzare l'opzione 2.

  1. Aprire Internet Explorer.
  2. Nell'angolo in alto a destra seleziona l'icona a forma di ingranaggio e quindi seleziona Opzioni Internet.
  3. Nella scheda Generale della sezione Cronologia esplorazioni selezionare Impostazioni.
  4. Selezionare la scheda Cache e database.
  5. Se viene visualizzata l'opzione Notifica quando la cache di un sito Web o un database supera, modificare il valore su 200 e selezionare OK. In alternativa, è possibile selezionare dynamics.com dall'elenco dei siti Web e quindi selezionare Supera limite. Se queste opzioni non vengono visualizzate, continuare con l'opzione 2.
  6. Cancella la cronologia e la cache di Internet Explorer. Per la procedura dettagliata, vedi Visualizzare ed eliminare la cronologia esplorazioni in Internet Explorer.

Opzione 2 - Aumentare il limite del database all'interno del Registro di sistema

Importante

Questa sezione contiene i passaggi che illustrano come modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedere Come eseguire il backup e il ripristino del Registro di sistema in Windows.

Per aumentare il limite consentito per la memorizzazione nella cache, creare la voce del Registro di sistema seguente:

Sottochiave: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
Nome: MaxTrustedDomainLimitInMB
Tipo: REG_DWORD
Dati: 200

Per creare questa voce del Registro di sistema, attenersi alla seguente procedura:

  1. Selezionare Start e quindi Esegui, digitare regedit e premere OK.

  2. Individuare e selezionare la seguente sottochiave del Registro di sistema. Se il percorso di questo percorso non esiste, potrebbe essere necessario creare le chiavi indicate:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue

  3. Fare clic con il pulsante destro del mouse su IndexedDBValue, scegliere Nuovo e quindi selezionare Valore DWORD.

  4. Nella casella Nuovo valore #1 digitare MaxTrustedDomainLimitInMB e quindi premere INVIO.

  5. Fare clic con il pulsante destro del mouse su MaxTrustedDomainLimitInMB e quindi scegliere Modifica.

  6. Selezionare Decimale, digitare 200 e quindi selezionare OK.

  7. Chiudere l'editor del Registro di sistema e riavviare il computer.

  8. Cancella la cronologia e la cache di Internet Explorer. Per la procedura dettagliata, vedi Visualizzare ed eliminare la cronologia esplorazioni in Internet Explorer.

Altre informazioni

Questo errore può essere generato da più possibili cause. Se il problema persiste, fare riferimento all'articolo seguente per ulteriori possibili soluzioni:

Errore "Non è possibile connettersi al server Microsoft Dynamics 365" quando si usa Dynamics 365 App per Outlook