Non è possibile interagire con l'applicazione desktop senza un messaggio di errore

Questo articolo fornisce una soluzione a un problema per cui non è possibile interagire con l'applicazione desktop senza un messaggio di errore in Microsoft Power Automate.

Si applica a: Power Automate
Numero KB originale: 5003775

Sintomi

È possibile che si verifichino i problemi seguenti:

  1. I clic o le sequenze di tasti del mouse non vengono inviati all'applicazione di destinazione, senza un messaggio di errore.
  2. Desktop recorder non riconosce gli elementi dell'applicazione desktop.

Problema di verifica

È possibile aprire il Power Automate per desktop Designer e provare a interagire con l'applicazione desktop con una delle azioni seguenti:

  • Inviare chiavi
  • Invia clic del mouse
  • Spostare il mouse nell'immagine

Aprire anche Registrazione desktop e provare a acquisire un elemento all'interno dell'applicazione.

Entrambe le operazioni precedenti non possono essere eseguite senza alcun messaggio di errore.

Causa

L'applicazione viene eseguita con privilegi più elevati rispetto a Power Automate per desktop.

Risoluzione

Sia l'applicazione che Power Automate per desktop devono essere eseguite con gli stessi privilegi.

Power Automate per desktop non viene eseguito con privilegi elevati per impostazione predefinita. Deselezionare quindi la casella di controllo Esegui questo programma come amministratore nella sezione Compatibilità della finestra Proprietà dell'applicazione.

Un'altra opzione consiste nell'impostare Power Automate per desktop da eseguire anche come amministratore.