Il flusso del desktop ha esito negativo con il codice di errore SessionCreationTimeout

Questo articolo fornisce una soluzione a un problema per cui le esecuzioni automatiche del flusso desktop hanno esito negativo e viene visualizzato il codice di errore SessionCreationTimeout in Microsoft Power Automate per desktop.

Si applica a: Power Automate
Numero KB originale: 5016026

Sintomi

Le esecuzioni automatiche del flusso desktop hanno esito negativo con il codice di errore SessionCreationTimeout (vedere lo screenshot seguente).

Dettagli del codice di errore SessionCreationTimeout.

Causa

Quando si crea una sessione di Windows per le esecuzioni automatiche, Power Automate per desktop ha un timeout predefinito di 3 minuti. Pertanto, se una connessione desktop remoto al computer richiede più di 3 minuti, le esecuzioni automatiche avranno esito negativo.

Risoluzione

La prima cosa da fare è assicurarsi di avere la versione più recente di Power Automate per desktop. Se il problema persiste, potrebbe essere necessario aumentare la durata del timeout della creazione della sessione di Windows. Si noti che questi passaggi sono supportati solo nelle versioni 2.21 o successive. A tal fine, attenersi alla seguente procedura:

  1. Aprire l'editor del Registro di sistema. Per aprirlo, è possibile aprire il menu Start e digitare Esegui per ottenere l'applicazione Esegui. Digitare regedit nel campo di testo e selezionare OK.

    Procedura per aprire l'editor del Registro di sistema.

  2. Nel percorso Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Power Automate Desktop\Servicecreare un nuovo DWORD e assegnargli il nome SessionCreationTimeoutSeconds. Il valore da assegnarvi è la durata massima in secondi consentita per la creazione della sessione. Lo screenshot seguente mostra un nuovo valore di timeout di cinque minuti.

    Passaggi per creare una nuova sessione DWORDCreationTimeoutSeconds con un valore di timeout.

  3. Riavviare il servizio Power Automate. A tale scopo, aprire l'applicazione Servizi, fare clic con il pulsante destro del mouse sul servizio Power Automate e scegliere Riavvia.

    Procedura per riavviare il servizio Power Automate.