Risolvere l'errore di credenziali non valide del flusso desktop tramite l'account AAD

Questo articolo fornisce una risoluzione per risolvere gli errori di InvalidConnectionCredentials o WindowsIdentityIncorrect durante l'esecuzione del flusso dell'interfaccia utente.

Si applica a: Power Automate
Numero KB originale: 4555623

Sintomi

Un flusso eseguito usando un account AAD ha esito negativo con i codici di errore InvalidConnectionCredentials o WindowsIdentityIncorrect .

Screenshot del codice di errore InvalidConnectionCredentials.

Screenshot del codice di errore WindowsIdentityIncorrect.

Causa

È possibile che questo errore venga visualizzato per molti motivi quando si usa un account AAD:

  • Le credenziali dell'account immesse nella connessione potrebbero non corrispondere a quelle del computer.
  • Il dispositivo potrebbe non essere aggiunto ad AAD (o aggiunto ad AAD ibrido) per supportare l'autenticazione di AAD.
  • L'account AAD potrebbe non essere sincronizzato con il computer.

Risoluzione

Prima di tutto, assicurarsi che il dispositivo sia aggiunto ad AAD o aggiunto a un dominio:

  1. Aprire la finestra del prompt dei comandi.
  2. Eseguire il comando dsregcmd /status.
  3. Controllare la sezione Stato dispositivo.

Screenshot dello stato del dispositivo nel prompt dei comandi quando si esegue dsregcmd /status.

Assicurarsi che uno dei DomainJoined valori o AzureAdJoined sia .

In caso contrario, non è possibile usare un account AAD a meno che il dispositivo non sia aggiunto, vedere la documentazione microsoft su Come aggiungere un dispositivo.

In secondo luogo, identificare l'account AAD da usare nella configurazione del computer:

  1. Aprire Impostazioni e selezionare Account.
  2. Selezionare Accedi all'azienda o all'istituto di istruzione.
  3. Assicurarsi di visualizzare un testo simile a Connesso a <your_organization> Azure AD. L'account con cui viene indicato che è connesso può essere usato nella connessione.

In terzo luogo, sincronizzare l'account AAD nel dispositivo. Procedura:

  1. Selezionare il pulsante Info quando si seleziona la connessione ad Azure AD nella schermata Accedi all'azienda o all'istituto di istruzione .
  2. Verrà aperta una schermata che descrive le informazioni di connessione e lo stato di sincronizzazione del dispositivo. Alla fine sarà presente un pulsante Sincronizza , selezionare questo pulsante e attendere il completamento del processo.

In quarto luogo, verificare che l'account AAD configurato possa accedere al dispositivo:

  1. Provare ad accedere al computer usando l'account AAD identificato nel passaggio precedente.
  2. L'accesso del dispositivo deve avere esito positivo per poter essere usato in una connessione.

Infine, assicurarsi che il flusso sia configurato correttamente con il nome utente e la password corretti. Questo corrisponde molto all'account nel computer.