Errore "L'utente della cassetta postale non dispone di autorizzazioni sufficienti" durante il test e l'abilitazione di una cassetta postale

Questo articolo fornisce una soluzione a un errore di autorizzazioni che si verifica quando si tenta di testare e abilitare una cassetta postale in Microsoft Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4052824

Sintomi

Quando si tenta di testare e abilitare una cassetta postale in Dynamics 365, viene registrato l'avviso seguente:

Gli appuntamenti, i contatti e le attività non possono essere sincronizzati per il nome> della cassetta postale perché l'utente della cassetta <postale non dispone di autorizzazioni sufficienti per questa cassetta postale.

Codice errore del server di posta elettronica: Crm.80048306.Privilegi non sufficienti per accedere all'oggetto Microsoft Dynamics 365 o eseguire l'operazione richiesta.

Se si sceglie di visualizzare i dettagli, vengono visualizzati i dettagli aggiuntivi seguenti:

T:195
ActivityId: <GUID>
>Eccezione: eccezione non gestita: Microsoft.Crm.CrmSecurityException: SecLib::AccessCheckEx non riuscita. Restituito hr = -2147187962, ObjectID: <GUID>, OwnerId: <GUID>, OwnerIdType: 8 e CallingUser: <GUID>. ObjectTypeCode: 4120, objectBusinessUnitId: <GUID>, AccessRights: WriteAccess at Microsoft.Crm.BusinessEntities.SecurityLibrary.AccessCheckEx2(ExecutionContext context, SecurityPrincipal principal, SecurityPrincipal ownerPrincipal, Guid objectId, Int32 objectTypeCode, Guid objectBusinessUnitId, AccessRights rights) all'indirizzo Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncUtility.HasExchangeSyncIdMappingAccess(Guid userId, Int32 userIdTypeCode, IACTProviderContextCode orgContext) presso Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncWorker.PerformPreMailboxSyncChecks() all'indirizzo Microsoft.Crm.Asynchronous.EmailConnector.ExchangeS...

Causa

L'utente di Dynamics 365 associato alla cassetta postale non dispone di privilegi sufficienti. Questo problema si verifica spesso perché all'utente non è assegnato un ruolo di sicurezza o il ruolo di sicurezza non dispone dell'accesso in lettura o scrittura a livello di utente all'entità Mailbox .

Importante

Verificare che il proprietario del record della cassetta postale corrisponda all'utente. Ad esempio, se la cassetta postale appartiene a Paul Cannon, assicurarsi che anche il valore Proprietario nel record sia Paul Cannon. Se viene visualizzato un utente diverso, l'utente potrebbe non avere accesso alla cassetta postale di Paul Cannon.

Risoluzione

Per risolvere il problema, seguire questa procedura:

  1. Aprire il record della cassetta postale come utente con il ruolo "Amministratore di sistema" in Dynamics 365.

    Suggerimento

    L'avviso include un collegamento al record della cassetta postale.

  2. Verificare che il campo Proprietario nel modulo della cassetta postale abbia il nome dell'utente. Se è elencato un altro nome, modificarlo con il nome dell'utente.

  3. Selezionare il collegamento nel campo Proprietario per aprire il record utente per l'utente proprietario.

  4. Selezionare Gestisci ruoli per visualizzare i ruoli di sicurezza assegnati all'utente.

  5. Passare a Impostazioni, selezionare Sicurezza e quindi ruoli di sicurezza.

  6. Aprire i ruoli trovati nel passaggio 4. Vedere PrivilegeDenied error si verifica quando si usa la sincronizzazione lato server per un elenco dei privilegi necessari e quindi verificare che il ruolo di sicurezza dell'utente contenga questi privilegi.

  7. Dopo aver verificato che l'utente sia il proprietario del record della cassetta postale e che il relativo ruolo di sicurezza contenga i privilegi necessari, selezionare di nuovo il pulsante Test e abilita cassetta postale nel record della cassetta postale. Se il test non genera esito positivo, esaminare il messaggio visualizzato nella sezione Avvisi .