Scenario: l'applicazione Apache Tez si blocca in Azure HDInsight
Questo articolo descrive le procedure di risoluzione dei problemi e le possibili soluzioni per i problemi che si verificano quando si interagisce con i cluster Azure HDInsight.
Problema
Dopo l'invio del processo Apache Hive, dalla visualizzazione Tez lo stato di processo è In esecuzione, ma non sembra fare progressi.
Causa
Troppi processi inviati; coda Yarn lunga.
Risoluzione
Aumentare le prestazioni del cluster o attendere che la coda Yarn venga svuotata.
Per impostazione predefinita, yarn.scheduler.capacity.maximum-applications
controlla il numero massimo di applicazioni in esecuzione o in sospeso e per impostazione predefinita è 10000
.
Passaggi successivi
Se il problema riscontrato non è presente in questo elenco o se non si riesce a risolverlo, visitare uno dei canali seguenti per ottenere ulteriore assistenza:
Ricevere risposte dagli esperti di Azure tramite la pagina Supporto della community per Azure.
Connettersi con @AzureSupport, l'account ufficiale Microsoft Azure per migliorare l'esperienza del cliente. Mette in contatto la community di Azure con le risorse giuste: risposte, supporto ed esperti.
Se serve ulteriore assistenza, è possibile inviare una richiesta di supporto dal portale di Azure. Selezionare Supporto nella barra dei menu o aprire l'hub Guida e supporto. Per informazioni più dettagliate, vedere Come creare una richiesta di supporto in Azure. L'accesso al supporto per la gestione delle sottoscrizioni e la fatturazione è incluso nella sottoscrizione di Microsoft Azure e il supporto tecnico viene fornito tramite uno dei piani di supporto di Azure.