Condividi tramite


Non è possibile eseguire la migrazione della cassetta postale primaria locale con archivio basato sul cloud a Exchange Online

Sintomi

In una distribuzione ibrida di Exchange sono disponibili una cassetta postale primaria Microsoft Exchange Server locale e una cassetta postale di archiviazione basata sul cloud in Exchange Online. Si tenta di eseguire la migrazione della cassetta postale primaria locale a Exchange Online usando il cmdlet New-MigrationBatch o New-MoveRequest insieme all'opzione PrimaryOnly . In questo caso, viene visualizzato il seguente messaggio di errore:

Il database di archiviazione non è impostato in modo esplicito nella cassetta postale. Di conseguenza, non è possibile consentire uno spostamento primario solo per questo utente.

Causa

Questo errore viene attivato da un controllo di convalida Exchange Online per la richiesta di spostamento. L'errore potrebbe verificarsi perché si dispone di cassette postali di archiviazione doppie (una cassetta postale di archiviazione locale e una cassetta postale di archiviazione basata sul cloud) e condividono lo stesso valore per il ArchiveGuid parametro . Questa situazione non è supportata. Di conseguenza, la migrazione non riesce e genera l'errore per evitare di perdere i dati di archivio nella cassetta postale primaria locale interessata.

Nota: l'unico scenario di archiviazione divisa supportato è una cassetta postale primaria locale e una cassetta postale di archiviazione in Exchange Online.

Risoluzione

Per correggere il problema, attenersi alla procedura seguente:

  1. Controllare il ArchiveGuid valore della proprietà delle cassette postali di archiviazione locali e basate sul cloud:

    Se entrambe le cassette postali di archiviazione hanno lo stesso ArchiveGuid valore di proprietà, passare al passaggio 2. In caso contrario, creare una richiesta di supporto.

  2. Eseguire il backup ed esportare la cassetta postale di archiviazione locale in un file pst:

    1. Aprire l'interfaccia di amministrazione di Exchange.

    2. Selezionare destinatari>cassette postali>Altre opzioni ( ) >Esporta in un file PST.

    3. Nella pagina Esporta in un file pst selezionare la cassetta postale di origine e quindi selezionare Esporta solo il contenuto dell'archivio> della cassetta postaleAvanti.

    4. Specificare il percorso per esportare il file pst e quindi selezionare Fine successiva>.

    Per altre informazioni, vedere Creare richieste di esportazione delle cassette postali.

  3. Aggiungere il dominio della cassetta postale di archiviazione basata sul cloud alla ArchiveDomain proprietà della cassetta postale primaria locale interessata:

    1. Aprire Exchange Management Shell ed eseguire il cmdlet Set-ADUser :

      Set-ADUser -Identity <name of affected mailbox> -Add @{msExchArchiveaddress="<domain name of cloud archive>"}
      
    2. Eseguire il Get-Mailbox cmdlet per verificare che il ArchiveDomain valore sia impostato correttamente:

      Get-Mailbox -Identity <name of affected mailbox> | FL *archive*
      
  4. Per eseguire la migrazione della cassetta postale primaria locale a Exchange Online, usare il New-MigrationBatch cmdlet o New-MoveRequest insieme all'opzione PrimaryOnly .