Il client outlook Microsoft Dynamics CRM 2011 non riesce a configurare l'indirizzo Web IFD esterno
Questo articolo fornisce una soluzione per il problema che gli utenti non possono configurare il client Microsoft Dynamics CRM Outlook all'indirizzo Web esterno e l'errore Impossibile connettersi a Microsoft Dynamics CRM server perché non è possibile autenticare le credenziali.
Si applica a: Microsoft Dynamics CRM 2011
Numero KB originale: 2912175
Sintomi
Quando la distribuzione Microsoft Dynamics CRM 2011 è configurata per la distribuzione con connessione Internet (IFD) tramite Active Directory Certificate Services (ADFS), gli utenti potrebbero ricevere l'errore seguente quando tentano di configurare il client outlook Microsoft Dynamics CRM all'indirizzo Web esterno:
Impossibile connettersi a Microsoft Dynamics CRM server perché non è possibile autenticare le credenziali. Controllare la connessione o contattare l'amministratore per ulteriori informazioni.
Quando si esamina il log di configurazione, viene acquisita anche l'eccezione seguente:
Errore durante la connessione all'URL:
https://crmorg.domain.com/XRMServices/2011/Discovery.svc
eccezione: System.ServiceModel.EndpointNotFoundException: nessun endpoint in ascoltohttps://adfs.domain.com/adfs/services/trust/13/username
poteva accettare il messaggio .
Tuttavia, gli utenti potrebbero comunque essere in grado di accedere all'URL esterno tramite un Web browser senza errori.
Causa
L'endpoint /adfs/services/trust/13/username può essere abilitato. Quando questo endpoint è abilitato, il client non sarà in grado di raggiungere gli endpoint usernamemixed e kerberosmixed, il che causa l'errore di autenticazione.
Risoluzione
Disabilitare l'endpoint /adfs/services/trust/13/username e riavviare il servizio ADFS. Per eseguire questa azione, vedere i passaggi seguenti:
- Aprire la console di gestione di AD FS.
- Nel riquadro di spostamento a sinistra espandere Servizio e quindi selezionare Endpoint.
- Nell'elenco degli endpoint individuare e fare clic con il pulsante destro del mouse sull'endpoint /adfs/services/trust/13/username.
- Selezionare Disabilita.
- Riavviare il servizio AD FS.