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La posta elettronica non riesce a eseguire la sincronizzazione con Microsoft Dynamics 365 quando viene codificata con pec

Questo articolo fornisce una soluzione a un problema a causa del quale la posta elettronica non riesce a eseguire la sincronizzazione con Microsoft Dynamics 365 quando viene codificata con pec.

Si applica a: Microsoft Dynamics CRM
Numero KB originale: 4490718

Introduzione

Che cosa sono i messaggi di posta elettronica PEC?

I messaggi di posta elettronica PEC sono messaggi di posta elettronica certificati usati in alcuni paesi/aree geografiche e hanno la stessa validità legale dei messaggi di posta elettronica registrati (s/mime).

S/MIME (Secure/Multipurpose Internet Mail Extensions) è un metodo ampiamente accettato, o più precisamente un protocollo, per l'invio di messaggi firmati digitalmente e crittografati.

S/MIME consente di crittografare i messaggi di posta elettronica e firmarli digitalmente.

Sintomi

I messaggi di posta elettronica pec non vengono sincronizzati con la sincronizzazione lato server o il router di posta elettronica.

Causa

La sincronizzazione lato server e il router di posta elettronica usano i servizi Web di Exchange per connettersi a exchange Server.

PEC e RFC6109 non usano API tramite REST o SOAP, ad esempio sincronizzazione lato server e router di posta elettronica non saranno in grado di sincronizzare correttamente questi messaggi di posta elettronica.

Risoluzione

Quando un messaggio di posta elettronica viene crittografato, crea un token inviato al destinatario del messaggio di posta elettronica.

Questa relazione uno-a-uno consente a un utente di inviare un messaggio di posta elettronica a un altro utente e di essere crittografato.

Cosa accade quando viene inviato un messaggio di posta elettronica crittografato:

Poiché Dynamics è un'applicazione di terze parti, quando tenta di accedere al messaggio di posta elettronica, riceverà questo messaggio di posta elettronica solo in uno stato crittografato.

Poiché il token non esiste in Dynamics 365, il messaggio di posta elettronica non verrà decrittografato.

  • Una crittografia univoca crittografa un messaggio di posta elettronica.
  • Il messaggio di posta elettronica viene codificato in testo crittografato.
  • Il messaggio di posta elettronica viene inviato e ricevuto.
  • Il ricevitore immette una chiave di crittografia per decodificare il messaggio.

PEC e RFC6109 non usano API tramite REST o SOAP, come ad esempio la sincronizzazione lato server e il router di posta elettronica non supporta questo tipo di posta elettronica per la sincronizzazione.

Per sincronizzare questo messaggio di posta elettronica con l'organizzazione dynamics 365, è necessario rimuovere la crittografia dal messaggio di posta elettronica, che può essere ottenuto inoltrando il messaggio di posta elettronica.